CVE-2017-12797
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5...
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5 on 32-bit platforms allows remote attackers to cause a denial of service via a crafted file, which triggers a heap-based buffer overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5 on 32-bit platforms allows remote attackers to cause a denial of service via a crafted file, which triggers a heap-based buffer overflow.
- Record
CVE-2017-12797- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-190
- Updated
- 2026-11-02
CVE List No score
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5 on 32-bit platforms allows remote attackers to cause a denial of service via a crafted file, which triggers a heap-based buffer overflow.
- Record
CVE-2017-12797- Updated
- 2026-11-02
EUVDEUVD-2017-4334 No score
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5 on 32-bit platforms allows remote attackers to cause a denial of service via a crafted file, which triggers a heap-based buffer overflow.
- Record
EUVD-2017-4334- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jr2w-425q-9mfc
5.5
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5...
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5 on 32-bit platforms allows remote attackers to cause a denial of service via a crafted file, which triggers a heap-based buffer overflow.
- Record
GHSA-jr2w-425q-9mfc- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
5.5
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5 on 32-bit platforms allows remote attackers to cause a denial of service via a crafted file, which triggers a heap-based buffer overflow.
- Record
CVE-2017-12797- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-12797
5.5
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5 on 32-bit platforms allows remote attackers to cause a denial of service via a crafted file, which triggers a heap-based buffer overflow.
- Record
DEBIAN-CVE-2017-12797- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-12797
5.5
Integer overflow in the INT123_parse_new_id3 function in the ID3 parser in mpg123 before 1.25.5 on 32-bit platforms allows remote attackers to cause a denial of service via a crafted file, which triggers a heap-based buffer overflow.
- Record
UBUNTU-CVE-2017-12797- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0341 No score
Updated mpg123 packages fix security vulnerabilities
mpg123 version 1.25.6 fix two buffer overflows, and several other non-security bugs.
- Record
MGASA-2017-0341- Updated
- 2026-11-02
OSVUSN-4806-1 No score
mpg123 vulnerability
It was discovered that mpg123 failed to handle certain malformed mp3 files. An attacker could use this vulnerability to potentially leak sensitive information or cause a crash.
- Record
USN-4806-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mpg123Debian:12 |
before 1.25.6-1 | 1.25.6-1 |
mpg123Debian:13 |
before 1.25.6-1 | 1.25.6-1 |
mpg123Debian:14 |
before 1.25.6-1 | 1.25.6-1 |
mpg123Mageia:5 |
before 1.25.6-1.mga5 | 1.25.6-1.mga5 |
mpg123Mageia:6 |
before 1.25.6-1.mga6 | 1.25.6-1.mga6 |
mpg123Ubuntu:Pro:14.04:LTS |
before 1.16.0-1ubuntu1.1+esm1, plus listed versions 1.15.3-1ubuntu11.16.0-1ubuntu11.16.0-1ubuntu1.1 |
1.16.0-1ubuntu1.1+esm1 |
mpg123Ubuntu:Pro:14.04:LTS From an advisory covering 4 CVEs |
before 1.16.0-1ubuntu1.1+esm2, plus listed versions 1.15.3-1ubuntu11.16.0-1ubuntu11.16.0-1ubuntu1.11.16.0-1ubuntu1.1+esm1 |
1.16.0-1ubuntu1.1+esm2 |
mpg123Ubuntu:Pro:16.04:LTS From an advisory covering 4 CVEs |
before 1.22.4-1ubuntu0.1+esm2, plus listed versions 1.22.2-11.22.4-11.22.4-1ubuntu0.1 |
1.22.4-1ubuntu0.1+esm2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-12797 is a medium vulnerability (CVSS 5.5) in Mpg123, published August 29, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 68th percentile. Fixed in mpg123 1.25.6-1.
References
sourceforge.net/p/mpg123/mailman/message/35987663
sourceforge.net/p/mpg123/bugs/254
nvd.nist.gov/vuln/detail/CVE-2017-12797
github.com/advisories/GHSA-jr2w-425q-9mfc
security-tracker.debian.org/tracker/CVE-2017-12797
advisories.mageia.org/MGASA-2017-0341.html
Show 9 moreShow less
bugs.mageia.org/show_bug.cgi?id=21692
lists.opensuse.org/opensuse-updates/2017-09/msg00044.html
mpg123.de/cgi-bin/news.cgi
ubuntu.com/security/CVE-2017-12797
cve.org/CVERecord?id=CVE-2017-12797
ubuntu.com/security/notices/USN-4806-1
ubuntu.com/security/CVE-2017-9545
ubuntu.com/security/CVE-2017-11126
ubuntu.com/security/CVE-2017-12839