CVE-2017-11126
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers...
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
- Record
CVE-2017-11126- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
- Record
CVE-2017-11126- Updated
- 2026-11-02
EUVDEUVD-2017-2763 No score
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
- Record
EUVD-2017-2763- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mfqq-9fqv-736q
5.5
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers...
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
- Record
GHSA-mfqq-9fqv-736q- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVALPINE-CVE-2017-11126
5.5
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
- Record
ALPINE-CVE-2017-11126- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
5.5
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
- Record
CVE-2017-11126- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2017-11126
5.5
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
- Record
DEBIAN-CVE-2017-11126- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-11126
5.5
The III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
- Record
UBUNTU-CVE-2017-11126- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11061-1 No score
libmpg123-0-1.29.0-1.2 on GA media
These are all security issues fixed in the libmpg123-0-1.29.0-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11061-1- Updated
- 2026-11-02
OSVUSN-4806-1 No score
mpg123 vulnerability
It was discovered that mpg123 failed to handle certain malformed mp3 files. An attacker could use this vulnerability to potentially leak sensitive information or cause a crash.
- Record
USN-4806-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mpg123Alpine:v3.3 |
before 1.25.4-r0 | 1.25.4-r0 |
mpg123Alpine:v3.4 |
before 1.25.4-r0 | 1.25.4-r0 |
mpg123Alpine:v3.5 |
before 1.25.4-r0 | 1.25.4-r0 |
mpg123Alpine:v3.6 |
before 1.25.4-r0 | 1.25.4-r0 |
mpg123Debian:12 |
before 1.25.3-1 | 1.25.3-1 |
mpg123Debian:13 |
before 1.25.3-1 | 1.25.3-1 |
mpg123Debian:14 |
before 1.25.3-1 | 1.25.3-1 |
mpg123Ubuntu:Pro:14.04:LTS |
before 1.16.0-1ubuntu1.1+esm1, plus listed versions 1.15.3-1ubuntu11.16.0-1ubuntu11.16.0-1ubuntu1.1 |
1.16.0-1ubuntu1.1+esm1 |
mpg123Ubuntu:Pro:14.04:LTS From an advisory covering 4 CVEs |
before 1.16.0-1ubuntu1.1+esm2, plus listed versions 1.15.3-1ubuntu11.16.0-1ubuntu11.16.0-1ubuntu1.11.16.0-1ubuntu1.1+esm1 |
1.16.0-1ubuntu1.1+esm2 |
mpg123Ubuntu:Pro:16.04:LTS From an advisory covering 4 CVEs |
before 1.22.4-1ubuntu0.1+esm2, plus listed versions 1.22.2-11.22.4-11.22.4-1ubuntu0.1 |
1.22.4-1ubuntu0.1+esm2 |
mpg123openSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 1.29.0-1.2 | 1.29.0-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11126 is a medium vulnerability (CVSS 5.5) in Mpg123, published July 10, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.37%, the 72nd percentile. Fixed in mpg123 1.25.4-r0.
References
blogs.gentoo.org/ago/2017/07/03/mpg123-global-buffer-overflow-in-iii_i_stereo-layer3-c
openwall.com/lists/oss-security/2017/07/10/4
nvd.nist.gov/vuln/detail/CVE-2017-11126
github.com/advisories/GHSA-mfqq-9fqv-736q
security.alpinelinux.org/vuln/CVE-2017-11126
security-tracker.debian.org/tracker/CVE-2017-11126