Every CVE Search/ Get API key

CVE-2017-12839

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123...

8.3 HighFix available

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123 through 1.25.5 allows remote attackers to cause a possible denial-of-service (out-of-bounds read) or possibly have unspecified other impact via a crafted mp3 file.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
Low

Exploit likelihood

2.81%Up 1.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.3

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123 through 1.25.5 allows remote attackers to cause a possible denial-of-service (out-of-bounds read) or possibly have unspecified other impact via a crafted mp3 file.

Record
CVE-2017-12839
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123 through 1.25.5 allows remote attackers to cause a possible denial-of-service (out-of-bounds read) or possibly have unspecified other impact via a crafted mp3 file.

Record
CVE-2017-12839
Updated
2026-11-02
EUVDEUVD-2017-4376 No score

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123 through 1.25.5 allows remote attackers to cause a possible denial-of-service (out-of-bounds read) or possibly have unspecified other impact via a crafted mp3 file.

Record
EUVD-2017-4376
Updated
2026-11-03
GitHub AdvisoriesGHSA-gv4j-f4j9-qr3q 8.3

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123...

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123 through 1.25.5 allows remote attackers to cause a possible denial-of-service (out-of-bounds read) or possibly have unspecified other impact via a crafted mp3 file.

Record
GHSA-gv4j-f4j9-qr3q
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
Weakness
CWE-125
Updated
2026-11-02
OSV 8.3

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123 through 1.25.5 allows remote attackers to cause a possible denial-of-service (out-of-bounds read) or possibly have unspecified other impact via a crafted mp3 file.

Record
CVE-2017-12839
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
Updated
2026-11-02
OSVDEBIAN-CVE-2017-12839 8.3

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123 through 1.25.5 allows remote attackers to cause a possible denial-of-service (out-of-bounds read) or possibly have unspecified other impact via a crafted mp3 file.

Record
DEBIAN-CVE-2017-12839
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2017-12839 8.3

A heap-based buffer over-read in the getbits function in src/libmpg123/getbits.h in mpg123 through 1.25.5 allows remote attackers to cause a possible denial-of-service (out-of-bounds read) or possibly have unspecified other impact via a crafted mp3 file.

Record
UBUNTU-CVE-2017-12839
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
Updated
2026-11-02
OSVUSN-4806-1 No score

mpg123 vulnerability

It was discovered that mpg123 failed to handle certain malformed mp3 files. An attacker could use this vulnerability to potentially leak sensitive information or cause a crash.

Record
USN-4806-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mpg123
Debian:12
before 1.25.6-1
1.25.6-1
mpg123
Debian:13
before 1.25.6-1
1.25.6-1
mpg123
Debian:14
before 1.25.6-1
1.25.6-1
mpg123
Ubuntu:Pro:14.04:LTS
before 1.16.0-1ubuntu1.1+esm2, plus listed versions
1.15.3-1ubuntu11.16.0-1ubuntu11.16.0-1ubuntu1.11.16.0-1ubuntu1.1+esm1
1.16.0-1ubuntu1.1+esm2
mpg123
Ubuntu:Pro:16.04:LTS
before 1.22.4-1ubuntu0.1+esm2, plus listed versions
1.22.2-11.22.4-11.22.4-1ubuntu0.1
1.22.4-1ubuntu0.1+esm2
mpg123
Ubuntu:Pro:14.04:LTS
From an advisory covering 4 CVEs
before 1.16.0-1ubuntu1.1+esm2, plus listed versions
1.15.3-1ubuntu11.16.0-1ubuntu11.16.0-1ubuntu1.11.16.0-1ubuntu1.1+esm1
1.16.0-1ubuntu1.1+esm2
mpg123
Ubuntu:Pro:16.04:LTS
From an advisory covering 4 CVEs
before 1.22.4-1ubuntu0.1+esm2, plus listed versions
1.22.2-11.22.4-11.22.4-1ubuntu0.1
1.22.4-1ubuntu0.1+esm2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-12839 is a high vulnerability (CVSS 8.3) in Mpg123, published May 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.81%, the 86th percentile. Fixed in mpg123 1.25.6-1.

References

Show 6 moreShow less
MoveEnter Open