Every CVE Search/ Get API key

CVE-2017-15091

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4...

7.1 HighFix available

CVE-2017-15091 is a high vulnerability (CVSS 7.1) in Powerdns Authoritative, published January 23, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.24%, the 69th percentile. Fixed in pdns 4.0.5-1.

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
High

Exploit likelihood

1.24%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.1

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.

Record
CVE-2017-15091
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:N/I:P/A:P
Weakness
CWE-863, CWE-358
Updated
2026-11-02
CVE List No score

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.

Record
CVE-2017-15091
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2017-6559 No score

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.

Record
EUVD-2017-6559
Updated
2026-11-03
GitHub AdvisoriesGHSA-c29m-p6xf-ppgw 7.1

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4...

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.

Record
GHSA-c29m-p6xf-ppgw
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
Weakness
CWE-358
Updated
2026-11-02
OSV 7.1

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.

Record
CVE-2017-15091
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-15091 7.1

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.

Record
DEBIAN-CVE-2017-15091
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-15091 7.1

An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.

Record
UBUNTU-CVE-2017-15091
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11156-1 No score

pdns-4.5.1-1.5 on GA media

These are all security issues fixed in the pdns-4.5.1-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11156-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pdns
Debian:12
before 4.0.5-1
4.0.5-1
pdns
Debian:13
before 4.0.5-1
4.0.5-1
pdns
Debian:14
before 4.0.5-1
4.0.5-1
pdns
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.4.5-1build23.4.6-23.4.6-33.4.7-13.4.7-2
Show 5 moreShow less
4.0.0~alpha1-14.0.0~alpha2-24.0.0~alpha2-34.0.0~alpha2-3build14.0.0~alpha2-3ubuntu0.1~esm1
None known
pdns
openSUSE:Tumbleweed
before 4.5.1-1.5
4.5.1-1.5

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 18 moreShow less
MoveEnter Open