CVE-2017-18009
Out-of-bounds Read in OpenCV
CVE-2017-18009 is a high vulnerability (CVSS 7.5) in Opencv, published January 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.47%, the 84th percentile. Fixed in opencv-python 3.4.1.15.
In OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
In OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
CVE-2017-18009- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
In OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
CVE-2017-18009- Updated
- 2026-11-02
EUVDEUVD-2021-2175 No score
In OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
EUVD-2021-2175- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-83rh-hx5x-q9p5
7.5
Out-of-bounds Read in OpenCV
In OpenCV 3.3.1 (corresponding with OpenCV-Python 3.3.1.11), a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
GHSA-83rh-hx5x-q9p5- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
7.5
In OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
CVE-2017-18009- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-18009
7.5
In OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
DEBIAN-CVE-2017-18009- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVGHSA-83rh-hx5x-q9p5
7.5
Out-of-bounds Read in OpenCV
In OpenCV 3.3.1 (corresponding with OpenCV-Python 3.3.1.11), a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
GHSA-83rh-hx5x-q9p5- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVPYSEC-2026-2810
7.5
Out-of-bounds Read in OpenCV
In OpenCV 3.3.1 (corresponding with OpenCV-Python 3.3.1.11), a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
PYSEC-2026-2810- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVPYSEC-2026-702
7.5
Out-of-bounds Read in OpenCV
In OpenCV 3.3.1 (corresponding with OpenCV-Python 3.3.1.11), a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
PYSEC-2026-702- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-18009
7.5
In OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
- Record
UBUNTU-CVE-2017-18009- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-4818-1 No score
opencv vulnerabilities
It was discovered that OpenCV did not properly manage certain objects, leading to a divide-by-zero. If a user were tricked into loading a specially crafted file, a remote attacker could potentially use this issue to cause a denial of service or possibly execute arbitrary code. (CVE-2019-15939)
It was discovered that OpenCV did not properly manage certain files, leading to an out of bounds read. If a user were tricked into loading a specially crafted file, a remote attacker could potentially use this issue to make OpenCV crash, resulting in a denial of service. This issue was only fixed in Ubuntu 18.04 ESM. (CVE-2019-14491, CVE-2019-14492)
It was discovered that OpenCV did not properly manage certain XML data, leading to a NULL pointer dereference. If a user were tricked into loading a specially crafted file, a remote attacker could potentially use this issue to make OpenCV crash, resulting in a denial of service. This issue was only fixed in Ubuntu 14.04 ESM and Ubuntu 16.04 ESM. (CVE-2019-14493)
It was discovered that OpenCV did not properly manage certain files, leading to a heap-based buffer overflow. If a user were tricked into loading a specially crafted file, a remote attacker could potentially use this issue to cause a denial of service or possibly execute arbitrary code. This issue only affected Ubuntu 18.04 ESM. (CVE-2017-18009)
- Record
USN-4818-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
opencv-pythonPyPI |
through 3.3.1.11 | 3.4.1.15 |
opencv-contrib-pythonPyPI |
through 3.3.1.11 | 3.4.1.15 |
opencvDebian:12 |
before 4.1.2+dfsg-3 | 4.1.2+dfsg-3 |
opencvDebian:13 |
before 4.1.2+dfsg-3 | 4.1.2+dfsg-3 |
opencvDebian:14 |
before 4.1.2+dfsg-3 | 4.1.2+dfsg-3 |
opencv-pythonPyPI |
before 3.4.1.15, plus listed versions 3.4.0.14 |
3.4.1.15 |
opencv-contrib-pythonPyPI |
before 3.4.1.15 | 3.4.1.15 |
opencvUbuntu:Pro:14.04:LTS |
before 2.4.8+dfsg1-2ubuntu1.2+esm1, plus listed versions 2.4.5+dfsg-0ubuntu42.4.5+dfsg-0ubuntu52.4.6.1+dfsg-2ubuntu22.4.6.1+dfsg-2ubuntu32.4.6.1+dfsg-2ubuntu4 Show 4 moreShow less2.4.6.1+dfsg-2ubuntu52.4.8+dfsg-1ubuntu12.4.8+dfsg1-2ubuntu12.4.8+dfsg1-2ubuntu1.2 |
2.4.8+dfsg1-2ubuntu1.2+esm1 |
opencvUbuntu:Pro:16.04:LTS |
before 2.4.9.1+dfsg-1.5ubuntu1.1+esm1, plus listed versions 2.4.9+dfsg-1ubuntu62.4.9.1+dfsg-1.2ubuntu12.4.9.1+dfsg-1.3ubuntu12.4.9.1+dfsg-1.5ubuntu12.4.9.1+dfsg-1.5ubuntu1.1 |
2.4.9.1+dfsg-1.5ubuntu1.1+esm1 |
opencvUbuntu:Pro:18.04:LTS |
before 3.2.0+dfsg-4ubuntu0.1+esm3, plus listed versions 3.1.0+dfsg1-1~exp1ubuntu33.2.0+dfsg-33.2.0+dfsg-43.2.0+dfsg-4build13.2.0+dfsg-4build23.2.0+dfsg-4ubuntu0.13.2.0+dfsg-4ubuntu0.1+esm2 |
3.2.0+dfsg-4ubuntu0.1+esm3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | affected | |
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
securityfocus.com/bid/106945
github.com/opencv/opencv/issues/10479
nvd.nist.gov/vuln/detail/CVE-2017-18009
github.com/opencv/opencv/pull/10480/commits/4ca89db22dea962690f31c1781bce5937ee91837
github.com/advisories/GHSA-83rh-hx5x-q9p5
security-tracker.debian.org/tracker/CVE-2017-18009
Show 10 moreShow less
github.com/opencv/opencv-python
pypi.org/project/opencv-python
pypi.org/project/opencv-contrib-python
ubuntu.com/security/CVE-2017-18009
ubuntu.com/security/notices/USN-4818-1
cve.org/CVERecord?id=CVE-2017-18009
ubuntu.com/security/CVE-2019-14491
ubuntu.com/security/CVE-2019-14492
ubuntu.com/security/CVE-2019-14493
ubuntu.com/security/CVE-2019-15939