Every CVE Search/ Get API key

CVE-2017-18076

Omniauth allows POST parameters to be stored in session

7.5 HighFix available

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

2.13%Up 1.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Record
CVE-2017-18076
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Updated
2026-11-02
CVE List No score

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Record
CVE-2017-18076
Updated
2026-11-02
EUVDEUVD-2018-0158 No score

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Record
EUVD-2018-0158
Updated
2026-11-03
GitHub AdvisoriesGHSA-9pr6-grf4-x2fr 7.5

Omniauth allows POST parameters to be stored in session

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Record
GHSA-9pr6-grf4-x2fr
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSV 7.5

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Record
CVE-2017-18076
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2017-18076 7.5

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Record
DEBIAN-CVE-2017-18076
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-9pr6-grf4-x2fr 7.5

Omniauth allows POST parameters to be stored in session

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Record
GHSA-9pr6-grf4-x2fr
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2017-18076 7.5

In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.

Record
UBUNTU-CVE-2017-18076
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
omniauth
RubyGems
before 1.3.2
1.3.2
ruby-omniauth
Debian:12
before 1.3.1-2
1.3.1-2
ruby-omniauth
Debian:13
before 1.3.1-2
1.3.1-2
ruby-omniauth
Debian:14
before 1.3.1-2
1.3.1-2
ruby-omniauth
Debian:8
before 1.2.1-1+deb8u1, plus listed versions
1.2.1-1
1.2.1-1+deb8u1
ruby-omniauth
Debian:9
before 1.3.1-1+deb9u1, plus listed versions
1.3.1-1
1.3.1-1+deb9u1
omniauth
RubyGems
before 1.3.2, plus listed versions
0.0.10.0.30.0.40.0.50.1.0
Show 39 moreShow less
0.1.10.1.20.1.30.1.40.1.50.1.60.2.00.2.0.beta10.2.0.beta20.2.0.beta30.2.0.beta40.2.0.beta50.2.10.2.20.2.30.2.40.2.50.2.60.3.00.3.0.rc30.3.21.0.01.0.0.beta11.0.0.pr11.0.0.pr21.0.0.rc11.0.0.rc21.0.11.0.21.0.31.1.01.1.11.1.21.1.31.1.41.2.11.2.21.3.01.3.1
1.3.2
ruby-omniauth
Ubuntu:16.04:LTS
before 1.3.1-1+deb9u1build0.16.04.1, plus listed versions
1.2.2-31.3.1-1
1.3.1-1+deb9u1build0.16.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-18076 is a high vulnerability (CVSS 7.5) in Omniauth, published January 26, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.13%, the 82nd percentile. Fixed in omniauth 1.3.2.

References

Show 5 moreShow less
MoveEnter Open