CVE-2017-18077
ReDoS in brace-expansion
index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.
- Record
CVE-2017-18077- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.
- Record
CVE-2017-18077- Updated
- 2026-11-02
EUVDEUVD-2018-0155 No score
index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.
- Record
EUVD-2018-0155- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-832h-xg76-4gv6
7.5
ReDoS in brace-expansion
Affected versions of brace-expansion are vulnerable to a regular expression denial of service condition.
Proof of Concept
var expand = require('brace-expansion');
expand('{,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,\n}');
Recommendation
Update to version 1.1.7 or later.
- Record
GHSA-832h-xg76-4gv6- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSV
7.5
index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.
- Record
CVE-2017-18077- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-18077
7.5
index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.
- Record
DEBIAN-CVE-2017-18077- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-832h-xg76-4gv6
7.5
ReDoS in brace-expansion
Affected versions of brace-expansion are vulnerable to a regular expression denial of service condition.
Proof of Concept
var expand = require('brace-expansion');
expand('{,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,\n}');
Recommendation
Update to version 1.1.7 or later.
- Record
GHSA-832h-xg76-4gv6- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSVRHSA-2020:2625
7.7
Red Hat Security Advisory: rh-nodejs8-nodejs security update
- Record
RHSA-2020:2625- CVSS 3.0
- 7.7 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVCLSA-2026-1792163293 No score
TuxCare security update for brace-expansion (1 CVE)
TuxCare rebuilt brace-expansion to address 1 CVE. Fixed in 1.1.3-tuxcare.1.
- Record
CLSA-2026-1792163293- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
brace-expansionnpm |
before 1.1.7 | 1.1.7 |
brace-expansionTuxCare:npm |
1.1.3-tuxcare.0 up to 1.1.3-tuxcare.1, plus listed versions 1.1.3 |
1.1.3-tuxcare.1 |
node-brace-expansionDebian:12 |
before 1.1.8-1 | 1.1.8-1 |
node-brace-expansionDebian:13 |
before 1.1.8-1 | 1.1.8-1 |
node-brace-expansionDebian:14 |
before 1.1.8-1 | 1.1.8-1 |
rh-nodejs8-nodejsRed Hat:rhel_software_collections:3::el7 |
before 0:8.17.0-2.el7 | 0:8.17.0-2.el7 |
rh-nodejs8-nodejs-debuginfoRed Hat:rhel_software_collections:3::el7 |
before 0:8.17.0-2.el7 | 0:8.17.0-2.el7 |
rh-nodejs8-nodejs-develRed Hat:rhel_software_collections:3::el7 |
before 0:8.17.0-2.el7 | 0:8.17.0-2.el7 |
rh-nodejs8-nodejs-docsRed Hat:rhel_software_collections:3::el7 |
before 0:8.17.0-2.el7 | 0:8.17.0-2.el7 |
rh-nodejs8-npmRed Hat:rhel_software_collections:3::el7 |
before 0:6.13.4-8.17.0.2.el7 | 0:6.13.4-8.17.0.2.el7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-18077 is a high vulnerability (CVSS 7.5) in Brace Expansion Project Expansion, published January 27, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.58%, the 85th percentile. Fixed in brace-expansion 1.1.7.
References
github.com/juliangruber/brace-expansion/pull/35/commits/b13381281cead487cbdbfd6a69fb097ea5e456c3
nodesecurity.io/advisories/338
github.com/juliangruber/brace-expansion/issues/33
bugs.debian.org/862712
nvd.nist.gov/vuln/detail/CVE-2017-18077
github.com/juliangruber/brace-expansion/pull/35
Show 37 moreShow less
github.com/advisories/GHSA-832h-xg76-4gv6
npmjs.com/advisories/338
security-tracker.debian.org/tracker/CVE-2017-18077
github.com/juliangruber/brace-expansion
access.redhat.com/errata/RHSA-2020:2625
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1448380
bugzilla.redhat.com/show_bug.cgi?id=1567228
bugzilla.redhat.com/show_bug.cgi?id=1578246
bugzilla.redhat.com/show_bug.cgi?id=1611613
bugzilla.redhat.com/show_bug.cgi?id=1788301
bugzilla.redhat.com/show_bug.cgi?id=1788305
bugzilla.redhat.com/show_bug.cgi?id=1788310
bugzilla.redhat.com/show_bug.cgi?id=1829414
security.access.redhat.com/data/csaf/v2/advisories/2020/rhsa-2020_2625.json
access.redhat.com/security/cve/CVE-2017-18077
cve.org/CVERecord?id=CVE-2017-18077
access.redhat.com/security/cve/CVE-2017-18869
cve.org/CVERecord?id=CVE-2017-18869
nvd.nist.gov/vuln/detail/CVE-2017-18869
access.redhat.com/security/cve/CVE-2018-3737
cve.org/CVERecord?id=CVE-2018-3737
nvd.nist.gov/vuln/detail/CVE-2018-3737
access.redhat.com/security/cve/CVE-2018-3750
cve.org/CVERecord?id=CVE-2018-3750
nvd.nist.gov/vuln/detail/CVE-2018-3750
hackerone.com/reports/311333
nodesecurity.io/advisories/612
access.redhat.com/security/cve/CVE-2019-16775
cve.org/CVERecord?id=CVE-2019-16775
nvd.nist.gov/vuln/detail/CVE-2019-16775
access.redhat.com/security/cve/CVE-2019-16776
cve.org/CVERecord?id=CVE-2019-16776
nvd.nist.gov/vuln/detail/CVE-2019-16776
access.redhat.com/security/cve/CVE-2019-16777
cve.org/CVERecord?id=CVE-2019-16777
nvd.nist.gov/vuln/detail/CVE-2019-16777