CVE-2017-2096
smalruby and smalruby-editor vulnerable to OS Command Injection
smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.
- Record
CVE-2017-2096- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.
- Record
CVE-2017-2096- Updated
- 2026-11-02
EUVDEUVD-2022-3682 No score
smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.
- Record
EUVD-2022-3682- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f489-655r-x6gr
9.8
smalruby and smalruby-editor vulnerable to OS Command Injection
smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.
- Record
GHSA-f489-655r-x6gr- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
9.8
smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.
- Record
CVE-2017-2096- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-f489-655r-x6gr
9.8
smalruby and smalruby-editor vulnerable to OS Command Injection
smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.
- Record
GHSA-f489-655r-x6gr- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
smalruby-editorRubyGems |
before 0.4.1 | 0.4.1 |
smalrubyRubyGems |
before 0.1.11 | 0.1.11 |
smalruby-editorRubyGems |
before 0.4.1, plus listed versions 0.0.10.0.100.0.110.0.120.0.2 Show 45 moreShow less0.0.30.0.40.0.50.0.60.0.70.0.80.0.90.1.00.1.10.1.100.1.110.1.120.1.130.1.140.1.150.1.160.1.170.1.180.1.190.1.20.1.200.1.210.1.220.1.230.1.240.1.30.1.40.1.50.1.60.1.70.1.80.1.90.2.00.2.10.2.20.2.30.2.40.2.50.2.60.2.70.3.00.3.10.3.20.3.30.3.4 |
0.4.1 |
smalrubyRubyGems |
before 0.1.11, plus listed versions 0.0.10.0.100.0.110.0.120.0.13 Show 38 moreShow less0.0.140.0.150.0.160.0.170.0.180.0.190.0.20.0.200.0.210.0.220.0.230.0.240.0.250.0.260.0.270.0.280.0.290.0.30.0.300.0.310.0.320.0.40.0.50.0.60.0.70.0.80.0.90.1.00.1.10.1.100.1.20.1.30.1.40.1.50.1.60.1.70.1.80.1.9 |
0.1.11 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-2096 is a critical vulnerability (CVSS 9.8) in Ruby Programming Shounendan Smalruby-editor, published April 28, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.18%, the 93rd percentile. Fixed in smalruby-editor 0.4.1.
References
jvn.jp/en/jp/JVN50197114/index.html
securityfocus.com/bid/95775
smalruby.jp/blog/2017/01/14/smalruby-editor-0-4-1-has-been-released-english.html
nvd.nist.gov/vuln/detail/CVE-2017-2096
web.archive.org/web/20200227194312/http://www.securityfocus.com/bid/95775
github.com/rubysec/ruby-advisory-db/blob/master/gems/smalruby/CVE-2017-2096.yml
github.com/advisories/GHSA-f489-655r-x6gr
github.com/smalruby/smalruby-editor
Left out here: 2 versions. The JSON record has them.