Every CVE Search/ Get API key

CVE-2017-5934

Moderate severity vulnerability that affects moin

6.1 MediumFix available

CVE-2017-5934 is a medium vulnerability (CVSS 6.1) in Moinmo Moinmoin, published December 31, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.94%, the 80th percentile. Fixed in moin 1.9.10.

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.94%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2017-5934
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2017-5934
Updated
2026-11-02
EUVDEUVD-2018-0101 No score

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
EUVD-2018-0101
Updated
2026-11-03
GitHub AdvisoriesGHSA-42fp-4hm3-j8r7 5.1

Moderate severity vulnerability that affects moin

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-42fp-4hm3-j8r7
CVSS 4.0
5.1 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2017-5934
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-42fp-4hm3-j8r7 5.1

Moderate severity vulnerability that affects moin

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-42fp-4hm3-j8r7
CVSS 4.0
5.1 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2017-5934 6.1

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
UBUNTU-CVE-2017-5934
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVPYSEC-2018-47 No score

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
PYSEC-2018-47
Updated
2026-11-02
OSVUSN-3794-1 No score

moin vulnerability

It was discovered that MoinMoin incorrectly handled certain inputs. An attacker could possibly use this issue to access sensitive information.

Record
USN-3794-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moin
PyPI
before 1.9.10
1.9.10
moin
Debian:8
before 1.9.8-1+deb8u2, plus listed versions
1.9.8-11.9.8-1+deb8u1
1.9.8-1+deb8u2
moin
Debian:9
before 1.9.9-1+deb9u1, plus listed versions
1.9.9-1
1.9.9-1+deb9u1
moin
PyPI
before 1.9.10, plus listed versions
1.8.41.8.51.8.61.8.71.9.0
Show 9 moreShow less
1.9.11.9.21.9.31.9.41.9.51.9.61.9.71.9.81.9.9
1.9.10
moin
Ubuntu:14.04:LTS
before 1.9.7-1ubuntu2.2, plus listed versions
1.9.5-5ubuntu11.9.7-1ubuntu11.9.7-1ubuntu21.9.7-1ubuntu2.1
1.9.7-1ubuntu2.2
moin
Ubuntu:16.04:LTS
before 1.9.8-1ubuntu1.16.04.2, plus listed versions
1.9.7-2ubuntu31.9.8-1ubuntu11.9.8-1ubuntu1.16.04.1
1.9.8-1ubuntu1.16.04.2
moin
Ubuntu:18.04:LTS
before 1.9.9-1ubuntu1.1, plus listed versions
1.9.9-1ubuntu1
1.9.9-1ubuntu1.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 7 moreShow less
MoveEnter Open