CVE-2017-5934
Moderate severity vulnerability that affects moin
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2017-5934- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2017-5934- Updated
- 2026-11-02
EUVDEUVD-2018-0101 No score
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2018-0101- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-42fp-4hm3-j8r7
5.1
Moderate severity vulnerability that affects moin
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-42fp-4hm3-j8r7- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2017-5934- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-42fp-4hm3-j8r7
5.1
Moderate severity vulnerability that affects moin
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-42fp-4hm3-j8r7- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-5934
6.1
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
UBUNTU-CVE-2017-5934- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVPYSEC-2018-47 No score
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
PYSEC-2018-47- Updated
- 2026-11-02
OSVUSN-3794-1 No score
moin vulnerability
It was discovered that MoinMoin incorrectly handled certain inputs. An attacker could possibly use this issue to access sensitive information.
- Record
USN-3794-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moinPyPI |
before 1.9.10 | 1.9.10 |
moinDebian:8 |
before 1.9.8-1+deb8u2, plus listed versions 1.9.8-11.9.8-1+deb8u1 |
1.9.8-1+deb8u2 |
moinDebian:9 |
before 1.9.9-1+deb9u1, plus listed versions 1.9.9-1 |
1.9.9-1+deb9u1 |
moinPyPI |
before 1.9.10, plus listed versions 1.8.41.8.51.8.61.8.71.9.0 Show 9 moreShow less1.9.11.9.21.9.31.9.41.9.51.9.61.9.71.9.81.9.9 |
1.9.10 |
moinUbuntu:14.04:LTS |
before 1.9.7-1ubuntu2.2, plus listed versions 1.9.5-5ubuntu11.9.7-1ubuntu11.9.7-1ubuntu21.9.7-1ubuntu2.1 |
1.9.7-1ubuntu2.2 |
moinUbuntu:16.04:LTS |
before 1.9.8-1ubuntu1.16.04.2, plus listed versions 1.9.7-2ubuntu31.9.8-1ubuntu11.9.8-1ubuntu1.16.04.1 |
1.9.8-1ubuntu1.16.04.2 |
moinUbuntu:18.04:LTS |
before 1.9.9-1ubuntu1.1, plus listed versions 1.9.9-1ubuntu1 |
1.9.9-1ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-5934 is a medium vulnerability (CVSS 6.1) in Moinmo Moinmoin, published December 31, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.94%, the 80th percentile. Fixed in moin 1.9.10.
References
github.com/moinwiki/moin-1.9/commit/70955a8eae091cc88fd9a6e510177e70289ec024
debian.org/security/2018/dsa-4318
moinmo.in/SecurityFixes
lists.debian.org/debian-lts-announce/2018/10/msg00007.html
usn.ubuntu.com/3794-1
lists.opensuse.org/opensuse-security-announce/2018-10/msg00024.html