CVE-2017-9300
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to...
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.
- Record
CVE-2017-9300- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.
- Record
CVE-2017-9300- Updated
- 2026-11-02
EUVDEUVD-2017-18236 No score
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.
- Record
EUVD-2017-18236- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8hr4-qhgg-4984
7.8
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to...
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.
- Record
GHSA-8hr4-qhgg-4984- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.8
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.
- Record
CVE-2017-9300- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-9300
7.8
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.
- Record
DEBIAN-CVE-2017-9300- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-9300
7.8
plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.
- Record
UBUNTU-CVE-2017-9300- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11502-1 No score
libvlc5-3.0.16-1.5 on GA media
These are all security issues fixed in the libvlc5-3.0.16-1.5 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11502-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vlcDebian:12 |
before 2.2.6-3 | 2.2.6-3 |
vlcDebian:13 |
before 2.2.6-3 | 2.2.6-3 |
vlcDebian:14 |
before 2.2.6-3 | 2.2.6-3 |
vlcDebian:8 |
before 2.2.7-1~deb8u1, plus listed versions 2.2.0-12.2.0~rc2-22.2.0~rc2-2+deb8u12.2.1-12.2.1-1~deb8u1 Show 43 moreShow less2.2.1-22.2.1-32.2.1-42.2.1-52.2.2-12.2.2-22.2.2-32.2.2-42.2.2-52.2.2-62.2.3-12.2.3-22.2.4-12.2.4-102.2.4-112.2.4-122.2.4-132.2.4-142.2.4-1~deb8u12.2.4-22.2.4-32.2.4-42.2.4-52.2.4-62.2.4-72.2.4-82.2.4-92.2.5-12.2.5-1~deb8u12.2.5-22.2.5-32.2.5-42.2.5.1-12.2.5.1-1~deb9u12.2.5.1-1~deb9u22.2.6-12.2.6-1~deb8u12.2.6-1~deb9u12.2.6-22.2.6-32.2.6-42.2.6-52.2.6-6 |
2.2.7-1~deb8u1 |
vlcDebian:9 |
before 2.2.7-1~deb9u1, plus listed versions 2.2.6-12.2.6-1~deb9u12.2.6-22.2.6-32.2.6-42.2.6-52.2.6-62.2.7-1~deb8u1 |
2.2.7-1~deb9u1 |
vlcUbuntu:14.04:LTS |
before 2.1.6-0ubuntu14.04.4, plus listed versions 2.0.8-12.1.1-12.1.2-12.1.2-22.1.2-2build1 Show 5 moreShow less2.1.2-2build22.1.4-0ubuntu14.04.12.1.6-0ubuntu14.04.12.1.6-0ubuntu14.04.22.1.6-0ubuntu14.04.3 |
2.1.6-0ubuntu14.04.4 |
vlcUbuntu:16.04:LTS |
before 2.2.2-5ubuntu0.16.04.4, plus listed versions 2.2.1-32.2.1-52.2.2-12.2.2-22.2.2-3 Show 6 moreShow less2.2.2-3build12.2.2-42.2.2-52.2.2-5ubuntu0.16.04.12.2.2-5ubuntu0.16.04.22.2.2-5ubuntu0.16.04.3 |
2.2.2-5ubuntu0.16.04.4 |
vlcopenSUSE:Tumbleweed |
before 3.0.16-1.5 | 3.0.16-1.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-9300 is a high vulnerability (CVSS 7.8) in Videolan Vlc Media Player, published May 29, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.42%, the 88th percentile. Fixed in vlc 2.2.6-3.
References
securityfocus.com/bid/98747
debian.org/security/2017/dsa-4045
code610.blogspot.com/2017/04/multiple-crashes-in-vlc-224.html
nvd.nist.gov/vuln/detail/CVE-2017-9300
github.com/advisories/GHSA-8hr4-qhgg-4984
security-tracker.debian.org/tracker/CVE-2017-9300
Show 19 moreShow less
ubuntu.com/security/CVE-2017-9300
cve.org/CVERecord?id=CVE-2017-9300
suse.com/security/cve/CVE-2017-10699
suse.com/security/cve/CVE-2017-9300
suse.com/security/cve/CVE-2018-19857
suse.com/security/cve/CVE-2019-13602
suse.com/security/cve/CVE-2019-13962
suse.com/security/cve/CVE-2019-14437
suse.com/security/cve/CVE-2019-14498
suse.com/security/cve/CVE-2019-14533
suse.com/security/cve/CVE-2019-14534
suse.com/security/cve/CVE-2019-14535
suse.com/security/cve/CVE-2019-14776
suse.com/security/cve/CVE-2019-14777
suse.com/security/cve/CVE-2019-14970
suse.com/security/cve/CVE-2019-5439
suse.com/security/cve/CVE-2019-5460
suse.com/security/cve/CVE-2020-13428
suse.com/security/cve/CVE-2020-26664