Every CVE Search/ Get API key

CVE-2017-10699

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of...

9.8 CriticalFix available

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.46%Up 2.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

Record
CVE-2017-10699
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

Record
CVE-2017-10699
Updated
2026-11-02
EUVDEUVD-2017-2345 No score

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

Record
EUVD-2017-2345
Updated
2026-11-03
GitHub AdvisoriesGHSA-6367-fpmm-r9xr 9.8

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of...

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

Record
GHSA-6367-fpmm-r9xr
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 9.8

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

Record
CVE-2017-10699
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-10699 9.8

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

Record
DEBIAN-CVE-2017-10699
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2017-10699 9.8

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

Record
UBUNTU-CVE-2017-10699
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0424 No score

Updated vlc packages fix security vulnerability

avcodec 2.2.x, as used in VideoLAN VLC media player before 2.2.7, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution (CVE-2017-10699).

The VLC packages have been updated to version 2.2.8, which includes various security improvements in decoders and demuxers, as well as other bug fixes.

Record
MGASA-2017-0424
Updated
2026-11-02
OSVMGASA-2017-0433 No score

Updated vlc packages fix security vulnerability

avcodec 2.2.x, as used in VideoLAN VLC media player before 2.2.7, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution (CVE-2017-10699).

The VLC packages have been updated to version 2.2.8, which includes various security improvements in decoders and demuxers, as well as other bug fixes.

Record
MGASA-2017-0433
Updated
2026-11-02
OSVopenSUSE-SU-2024:11502-1 No score

libvlc5-3.0.16-1.5 on GA media

These are all security issues fixed in the libvlc5-3.0.16-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11502-1
Updated
2026-11-02
OSVUSN-4805-1 No score

vlc vulnerabilities

It was discovered that VLC mishandled certain crafted media files. An attacker could use this vulnerability to cause a denial of service (crash) or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 ESM. (CVE-2017-10699)

It was discovered that VLC mishandled certain crafted MKV files. An attacker could use this vulnerability to cause a denial of service (crash) or possibly execute arbitrary code. (CVE-2018-11529)

Record
USN-4805-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vlc
Debian:12
before 2.2.6-3
2.2.6-3
vlc
Debian:13
before 2.2.6-3
2.2.6-3
vlc
Debian:14
before 2.2.6-3
2.2.6-3
vlc
Debian:8
before 2.2.7-1~deb8u1, plus listed versions
2.2.0-12.2.0~rc2-22.2.0~rc2-2+deb8u12.2.1-12.2.1-1~deb8u1
Show 43 moreShow less
2.2.1-22.2.1-32.2.1-42.2.1-52.2.2-12.2.2-22.2.2-32.2.2-42.2.2-52.2.2-62.2.3-12.2.3-22.2.4-12.2.4-102.2.4-112.2.4-122.2.4-132.2.4-142.2.4-1~deb8u12.2.4-22.2.4-32.2.4-42.2.4-52.2.4-62.2.4-72.2.4-82.2.4-92.2.5-12.2.5-1~deb8u12.2.5-22.2.5-32.2.5-42.2.5.1-12.2.5.1-1~deb9u12.2.5.1-1~deb9u22.2.6-12.2.6-1~deb8u12.2.6-1~deb9u12.2.6-22.2.6-32.2.6-42.2.6-52.2.6-6
2.2.7-1~deb8u1
vlc
Debian:9
before 2.2.7-1~deb9u1, plus listed versions
2.2.6-12.2.6-1~deb9u12.2.6-22.2.6-32.2.6-42.2.6-52.2.6-62.2.7-1~deb8u1
2.2.7-1~deb9u1
vlc
Mageia:5
before 2.2.8-1.0.mga5
2.2.8-1.0.mga5
vlc
Mageia:5
before 2.2.8-1.0.mga5.tainted
2.2.8-1.0.mga5.tainted
vlc
Ubuntu:Pro:14.04:LTS
before 2.1.6-0ubuntu14.04.5+esm1, plus listed versions
2.0.8-12.1.1-12.1.2-12.1.2-22.1.2-2build1
Show 7 moreShow less
2.1.2-2build22.1.4-0ubuntu14.04.12.1.6-0ubuntu14.04.12.1.6-0ubuntu14.04.22.1.6-0ubuntu14.04.32.1.6-0ubuntu14.04.42.1.6-0ubuntu14.04.5
2.1.6-0ubuntu14.04.5+esm1
vlc
Ubuntu:16.04:LTS
before 2.2.2-5ubuntu0.16.04.3, plus listed versions
2.2.1-32.2.1-52.2.2-12.2.2-22.2.2-3
Show 5 moreShow less
2.2.2-3build12.2.2-42.2.2-52.2.2-5ubuntu0.16.04.12.2.2-5ubuntu0.16.04.2
2.2.2-5ubuntu0.16.04.3
vlc
Ubuntu:Pro:16.04:LTS
before 2.2.2-5ubuntu0.16.04.5+esm1, plus listed versions
2.2.1-32.2.1-52.2.2-12.2.2-22.2.2-3
Show 7 moreShow less
2.2.2-3build12.2.2-42.2.2-52.2.2-5ubuntu0.16.04.12.2.2-5ubuntu0.16.04.22.2.2-5ubuntu0.16.04.32.2.2-5ubuntu0.16.04.4
2.2.2-5ubuntu0.16.04.5+esm1
vlc
openSUSE:Tumbleweed
before 3.0.16-1.5
3.0.16-1.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-10699 is a critical vulnerability (CVSS 9.8) in Videolan Vlc Media Player, published June 30, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.46%, the 91st percentile. Fixed in vlc 2.2.6-3.

References

Show 26 moreShow less
MoveEnter Open