CVE-2018-10908
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without...
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.5
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.
- Record
CVE-2018-10908- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-20, CWE-770
- Updated
- 2026-11-02
EUVDEUVD-2018-2964
6.5
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.
- Record
EUVD-2018-2964- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c34h-7mjf-54vf
6.3
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without...
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.
- Record
GHSA-c34h-7mjf-54vf- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H - Weakness
- CWE-770
- Updated
- 2026-11-02
NVD
6.5
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.
- Record
CVE-2018-10908- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H - CVSS 2.0
- 7.1 High
AV:N/AC:M/Au:N/C:N/I:N/A:C - Weakness
- CWE-20, CWE-770
- Updated
- 2026-11-02
OSV
6.3
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.
- Record
CVE-2018-10908- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H - Updated
- 2026-11-02
OSVRHEA-2018:2624
6.5
Red Hat Enhancement Advisory: VDSM bug fix and enhancement update 4.2
- Record
RHEA-2018:2624- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vdsmRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-apiRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-clientRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-commonRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-glusterRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-checkipsRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-cpuflagsRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-ethtool-optionsRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-extra-ipv4-addrsRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-fcoeRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
Show 11 moreShow less
| Package | Affected | Fixed |
|---|---|---|
vdsm-hook-localdiskRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-macspoofRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-nestedvtRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-openstacknetRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-vhostmdRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-hook-vmfex-devRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-httpRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-jsonrpcRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-networkRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-pythonRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
vdsm-yajsonrpcRed Hat:enterprise_linux:7::hypervisor |
before 0:4.20.39-1.el7ev | 0:4.20.39-1.el7ev |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-10908 is a medium vulnerability (CVSS 6.5) in [unknown] Vdsm, published August 9, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 67th percentile. Fixed in vdsm 0:4.20.39-1.el7ev.
References
bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10908
access.redhat.com/errata/RHEA-2018:2624
lists.nongnu.org/archive/html/qemu-block/2018-07/msg00488.html
gerrit.ovirt.org
nvd.nist.gov/vuln/detail/CVE-2018-10908
github.com/advisories/GHSA-c34h-7mjf-54vf
Show 7 moreShow less
bugzilla.redhat.com/show_bug.cgi?id=1612904
bugzilla.redhat.com/show_bug.cgi?id=1614657
bugzilla.redhat.com/show_bug.cgi?id=1618352
security.access.redhat.com/data/csaf/v2/advisories/2018/rhea-2018_2624.json
access.redhat.com/security/cve/CVE-2018-10908
bugzilla.redhat.com/show_bug.cgi?id=1605065
cve.org/CVERecord?id=CVE-2018-10908