Every CVE Search/ Get API key

CVE-2018-10908

It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without...

6.5 MediumFix available

It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.19%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.5

It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.

Record
CVE-2018-10908
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20, CWE-770
Updated
2026-11-02
EUVDEUVD-2018-2964 6.5

It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.

Record
EUVD-2018-2964
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-c34h-7mjf-54vf 6.3

It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without...

It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.

Record
GHSA-c34h-7mjf-54vf
CVSS 3.0
6.3 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H
Weakness
CWE-770
Updated
2026-11-02
NVD 6.5

It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.

Record
CVE-2018-10908
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 3.0
6.3 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H
CVSS 2.0
7.1 HighAV:N/AC:M/Au:N/C:N/I:N/A:C
Weakness
CWE-20, CWE-770
Updated
2026-11-02
OSV 6.3

It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.

Record
CVE-2018-10908
CVSS 3.0
6.3 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H
Updated
2026-11-02
OSVRHEA-2018:2624 6.5

Red Hat Enhancement Advisory: VDSM bug fix and enhancement update 4.2

Record
RHEA-2018:2624
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vdsm
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-api
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-client
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-common
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-gluster
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-checkips
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-cpuflags
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-ethtool-options
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-extra-ipv4-addrs
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-fcoe
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
Show 11 moreShow less
Affected packages
PackageAffectedFixed
vdsm-hook-localdisk
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-macspoof
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-nestedvt
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-openstacknet
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-vhostmd
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-hook-vmfex-dev
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-http
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-jsonrpc
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-network
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-python
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev
vdsm-yajsonrpc
Red Hat:enterprise_linux:7::hypervisor
before 0:4.20.39-1.el7ev
0:4.20.39-1.el7ev

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-10908 is a medium vulnerability (CVSS 6.5) in [unknown] Vdsm, published August 9, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 67th percentile. Fixed in vdsm 0:4.20.39-1.el7ev.

References

Show 7 moreShow less
MoveEnter Open