Every CVE Search/ Get API key

CVE-2018-15687

systemd: chown_one() can dereference symlinks

7.8 HighPublic exploitFix available

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.06%Down 4.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.8

systemd: chown_one() can dereference symlinks

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.

Record
CVE-2018-15687
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-362
Updated
2026-11-02
EUVDEUVD-2018-7557 7.8

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.

Record
EUVD-2018-7557
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-wxcv-623q-99fj 7.0

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary...

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.

Record
GHSA-wxcv-623q-99fj
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-362
Updated
2026-11-02
NVD 7.0

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.

Record
CVE-2018-15687
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.9 MediumAV:L/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-362
Updated
2026-11-02
OSV 7.0

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.

Record
CVE-2018-15687
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-15687 7.0

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.

Record
DEBIAN-CVE-2018-15687
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-15687 7.0

A race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.

Record
UBUNTU-CVE-2018-15687
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
4.7 MediumCVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:11420-1 No score

libsystemd0-249.4-2.2 on GA media

These are all security issues fixed in the libsystemd0-249.4-2.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11420-1
Updated
2026-11-02
OSVUSN-3816-1 No score

systemd vulnerabilities

Jann Horn discovered that unit_deserialize incorrectly handled status messages above a certain length. A local attacker could potentially exploit this via NotifyAccess to inject arbitrary state across re-execution and obtain root privileges. (CVE-2018-15686)

Jann Horn discovered a race condition in chown_one(). A local attacker could potentially exploit this by setting arbitrary permissions on certain files to obtain root privileges. This issue only affected Ubuntu 18.04 LTS and Ubuntu 18.10. (CVE-2018-15687)

It was discovered that systemd-tmpfiles mishandled symlinks in non-terminal path components. A local attacker could potentially exploit this by gaining ownership of certain files to obtain root privileges. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-6954)

Record
USN-3816-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
systemd
Debian:12
before 239-11
239-11
systemd
Debian:13
before 239-11
239-11
systemd
Debian:14
before 239-11
239-11
systemd
Ubuntu:16.04:LTS
before 229-4ubuntu21.8, plus listed versions
225-1ubuntu9227-2ubuntu1227-2ubuntu2228-1ubuntu2228-2ubuntu1
Show 34 moreShow less
228-2ubuntu2228-3ubuntu1228-4ubuntu1228-4ubuntu2228-5ubuntu1228-5ubuntu2228-5ubuntu3228-6ubuntu1229-1ubuntu2229-1ubuntu4229-2ubuntu1229-3ubuntu1229-3ubuntu2229-4ubuntu1229-4ubuntu4229-4ubuntu5229-4ubuntu6229-4ubuntu7229-4ubuntu8229-4ubuntu10229-4ubuntu11229-4ubuntu12229-4ubuntu13229-4ubuntu16229-4ubuntu17229-4ubuntu19229-4ubuntu20229-4ubuntu21229-4ubuntu21.1229-4ubuntu21.2229-4ubuntu21.3229-4ubuntu21.4229-4ubuntu21.5229-4ubuntu21.6
229-4ubuntu21.8
systemd
Ubuntu:18.04:LTS
before 237-3ubuntu10.6, plus listed versions
234-2ubuntu12235-2ubuntu3235-3ubuntu2235-3ubuntu3237-3ubuntu3
Show 8 moreShow less
237-3ubuntu4237-3ubuntu6237-3ubuntu7237-3ubuntu8237-3ubuntu10237-3ubuntu10.2237-3ubuntu10.3237-3ubuntu10.4
237-3ubuntu10.6
systemd
Ubuntu:16.04:LTS
From an advisory covering 3 CVEs
before 229-4ubuntu21.8, plus listed versions
225-1ubuntu9227-2ubuntu1227-2ubuntu2228-1ubuntu2228-2ubuntu1
Show 34 moreShow less
228-2ubuntu2228-3ubuntu1228-4ubuntu1228-4ubuntu2228-5ubuntu1228-5ubuntu2228-5ubuntu3228-6ubuntu1229-1ubuntu2229-1ubuntu4229-2ubuntu1229-3ubuntu1229-3ubuntu2229-4ubuntu1229-4ubuntu4229-4ubuntu5229-4ubuntu6229-4ubuntu7229-4ubuntu8229-4ubuntu10229-4ubuntu11229-4ubuntu12229-4ubuntu13229-4ubuntu16229-4ubuntu17229-4ubuntu19229-4ubuntu20229-4ubuntu21229-4ubuntu21.1229-4ubuntu21.2229-4ubuntu21.3229-4ubuntu21.4229-4ubuntu21.5229-4ubuntu21.6
229-4ubuntu21.8
systemd
Ubuntu:18.04:LTS
From an advisory covering 3 CVEs
before 237-3ubuntu10.6, plus listed versions
234-2ubuntu12235-2ubuntu3235-3ubuntu2235-3ubuntu3237-3ubuntu3
Show 8 moreShow less
237-3ubuntu4237-3ubuntu6237-3ubuntu7237-3ubuntu8237-3ubuntu10237-3ubuntu10.2237-3ubuntu10.3237-3ubuntu10.4
237-3ubuntu10.6
systemd
openSUSE:Tumbleweed
From an advisory covering 19 CVEs
before 249.4-2.2
249.4-2.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBsystemd - 'chown_one()' Dereference Symlinks2018-10-29

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-15687 is a high vulnerability (CVSS 7.8) in Systemd, published October 26, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. Fixed in systemd 239-11.

References

Show 26 moreShow less
MoveEnter Open