systemd vulnerabilities (Debian)
66 vulnerabilities.
-
systemdDebian systemd-homed: local privilege escalation via missing home-record signature verification on the authenticate path 6.7 Medium -
systemdDebian systemd-machined: unprivileged users can terminate arbitrary processes 4.7 Medium -
systemdDebian systemd-oomd: unprivileged users can terminate arbitrary processes 5.5 Medium -
systemdDebian In systemd 259, systemd-journald can send ANSI escape sequences to the terminals of arbitrary... 2.9 Low -
systemdDebian In systemd 260 before 261, a local unprivileged user can trigger an assert via an IPC API call... 6.2 Medium -
systemdDebian In nspawn in systemd 233 through 259 before 260, an escape-to-host action can occur via a crafted... 6.4 Medium -
systemdDebian In udev in systemd before 260, local root execution can occur via malicious hardware devices and... 6.4 Medium -
systemdDebian In systemd 259 before 260, there is local privilege escalation in systemd-machined because... 6.7 Medium -
systemdDebian In systemd 258 before 260, a local unprivileged user can trigger an assert when a Delegate=yes... 4.7 Medium -
systemdDebian systemd: Local unprivileged user can trigger an assert 5.5 Medium -
systemdDebian Systemd: systemd: privilege escalation via improper access control in registermachine d-bus method 6.7 Medium -
systemdDebian Systemd-coredump: race condition that allows a local attacker to crash a suid program and gain read access to the resulting core dump 4.7 Medium -
systemdDebian The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
systemdDebian Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
systemdDebian Systemd-resolved: unsigned name response in signed zone is not refused when dnssec=yes 5.9 Medium -
systemdDebian An issue was discovered in systemd 253. An attacker can modify the contents of past events in a... 5.3 Medium -
systemdDebian An issue was discovered in systemd 253. An attacker can truncate a sealed log file and then... 5.3 Medium -
systemdDebian An issue was discovered in systemd 253. An attacker can modify a sealed log file such that, in... 5.3 Medium -
systemdDebian systemd before 247 does not adequately block local privilege escalation for some Sudo... 7.8 High -
systemdDebian A vulnerability was found in systemd. This security flaw can cause a local information leak due... 5.5 Medium -
systemdDebian systemd 250 and 251 allows local users to achieve a systemd-coredump deadlock by triggering a... 5.5 Medium -
systemdDebian An off-by-one Error issue was discovered in Systemd in format_timespan() function of time-util.c.... 5.5 Medium -
systemdDebian A use-after-free vulnerability was found in systemd. This issue occurs due to the on_stream_io()... 9.8 Critical -
systemdDebian A flaw was found in systemd. An uncontrolled recursion in systemd-tmpfiles may lead to a denial... 5.5 Medium -
systemdDebian basic/unit-name.c in systemd 220 through 248 has a Memory Allocation with an Excessive Size Value... 5.5 Medium -
systemdDebian An exploitable denial-of-service vulnerability exists in Systemd 245. A specially crafted DHCP... 6.1 Medium -
systemdDebian systemd through v245 mishandles numerical usernames such as ones composed of decimal digits or 0x... 6.7 Medium -
systemdDebian systemd 37-1 does not properly handle non-existent services, which causes a denial of service ... 5.5 Medium -
systemdDebian A heap use-after-free vulnerability was found in systemd before version v245-rc1, where... 7.8 High -
systemdDebian An issue was discovered in button_open in login/logind-button.c in systemd before 243. When... 2.4 Low -
systemdDebian systemd 239 through 243 accepts any certificate signed by a trusted certificate authority for DNS... 9.8 Critical -
systemdDebian In systemd 240, bus_open_system_watch_bind_with_description in shared/bus-util.c (as used by... 4.4 Medium -
systemdDebian It was discovered that a systemd service that uses DynamicUser property can create a SUID/SGID... 4.5 Medium -
systemdDebian It was discovered that a systemd service that uses DynamicUser property can get new privileges... 4.5 Medium -
systemdDebian systemd - regression update No score -
systemdDebian In systemd before v242-rc4, it was discovered that pam_systemd does not properly sanitize the... 4.5 Medium -
systemdDebian An issue was discovered in sd-bus in systemd 239. bus_process_object() in libsystemd/sd-bus/bus... 5.5 Medium -
systemdDebian A memory leak was discovered in the backport of fixes for CVE-2018-16864 in Red Hat Enterprise... 3.3 Low -
systemdDebian systemd - regression update No score -
systemdDebian It was discovered systemd does not correctly check the content of PIDFile files before using it... 4.4 Medium -
systemdDebian An out of bounds read was discovered in systemd-journald in the way it parses log messages that... 4.3 Medium -
systemdDebian An allocation of memory without limits, that could result in the stack clashing with another... 7.5 High -
systemdDebian An allocation of memory without limits, that could result in the stack clashing with another... 7.4 High -
systemdDebian Out-of-Bounds write in systemd-networkd dhcpv6 option handling 8.8 High -
systemdDebian systemd: chown_one() can dereference symlinks 7.8 High -
systemdDebian systemd: reexec state injection: fgets() on overlong lines leads to line splitting 7.0 High -
systemdDebian systemd-tmpfiles in systemd through 237 mishandles symlinks present in non-terminal path... 7.8 High -
systemdDebian systemd-tmpfiles in systemd before 237 attempts to support ownership/permission changes on... 7.8 High -
systemdDebian In systemd prior to 234 a race condition exists between .mount and .automount units such that... 5.9 Medium -
systemdDebian In systemd 223 through 235, a remote DNS server can respond with a custom crafted DNS NSEC... 7.5 High - Show olderLoading…