Every CVE Search/ Get API key

CVE-2019-15107

An issue was discovered in Webmin through 1.920. The parameter old in password_change.cgi...

9.8 CriticalIn KEVPublic exploitFix available

An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

99.7%Up 59.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.

Record
CVE-2019-15107
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-78
Updated
2026-11-02
CVE List 9.8

An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.

Record
CVE-2019-15107
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
EUVDEUVD-2019-6178 9.8

An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.

Record
EUVD-2019-6178
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-69hp-hrv4-rxrr 9.8

An issue was discovered in Webmin through 1.920. The parameter old in password_change.cgi...

An issue was discovered in Webmin through 1.920. The parameter old in password_change.cgi contains a command injection vulnerability.

Record
GHSA-69hp-hrv4-rxrr
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
CISA KEV No score

Webmin Command Injection Vulnerability

An issue was discovered in Webmin. The parameter old in password_change.cgi contains a command injection vulnerability.

Record
CVE-2019-15107
Weakness
CWE-78
Updated
2026-11-02
OSV 9.8

An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.

Record
CVE-2019-15107
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0237 No score

Updated webmin packages fix security vulnerability

Updated webmin package fixes security vulnerability:

Webmin before 1.930 allows remote exploits if the option to change expired passwords is enabled (CVE-2019-15107).

Note that it is only vulnerable if changing of expired passwords is enabled, which is not the case by default.

Record
MGASA-2019-0237
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
webmin
Mageia:7
before 1.930-1.mga7
1.930-1.mga7

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
MetasploitWebmin password_change.cgi Backdoor2019-08-10
Exploit-DBWebmin 1.920 - Unauthenticated Remote Code Execution (Metasploit)2019-08-12
Exploit-DBWebmin 1.920 - Remote Code Execution2019-08-19
PoC in GitHubjas502n/CVE-2019-151072019-08-19
PoC in GitHubHACHp1/webmin_docker_and_exp2019-08-22
PoC in GitHubketlerd/CVE-2019-151072019-08-22
PoC in GitHubAdministratorGithub/CVE-2019-151072019-08-23
PoC in GitHubRayferrufino/Make-and-Break2019-09-23
PoC in GitHubAleWong/WebminRCE-EXP-CVE-2019-15107-2019-10-24
PoC in GitHubianxtianxt/CVE-2019-151072019-12-15
Show 19 moreShow less
Public exploits
SourceLinkDate
PoC in GitHubhannob/webminex2019-12-25
PoC in GitHubch4ko/webmin_CVE-2019-151072019-12-29
PoC in GitHubcdedmondson/Modified-CVE-2019-151072020-06-20
PoC in GitHubruthvikvegunta/CVE-2019-151072020-08-08
PoC in GitHubn0obit4/Webmin_1.890-POC2020-09-13
PoC in GitHubsquid22/Webmin_CVE-2019-151072020-10-15
PoC in GitHubMuirlandOracle/CVE-2019-151072020-11-09
PoC in GitHubdiegojuan/CVE-2019-151072020-12-03
PoC in GitHubwhokilleddb/CVE-2019-151072021-07-02
PoC in GitHubdarrenmartyn/CVE-2019-151072021-09-09
PoC in GitHubhacknotes/CVE-2019-15107-Exploit2021-10-05
PoC in GitHubCyberTuz/CVE-2019-15107_detection2021-10-10
PoC in GitHubhadrian3689/webmin_1.9202022-02-21
PoC in GitHubf0rkr/CVE-2019-151072022-04-18
PoC in GitHubpsw01/CVE-2019-15107_webminRCE2022-06-17
PoC in GitHubTheAlpha19/MiniExploit2022-07-26
PoC in GitHubwenruoya/CVE-2019-151072023-03-09
PoC in GitHubg1vi/CVE-2019-151072023-03-31
NucleiWebmin <= 1.920 - Unauthenticated Remote Command Execution

Plus 17 more. The full list has every link.

History

History
RecordedChangedSources
exploitation
exploits, exploits_more
exploits
first indexedCVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-15107 is a critical vulnerability (CVSS 9.8) in Webmin, published August 16, 2019. CISA lists it as known to be exploited, since March 25, 2022. EUVD reports exploitation since March 25, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 99.7%, the 99th percentile. Fixed in webmin 1.930-1.mga7.

References

Show 8 moreShow less
MoveEnter Open