CVE-2019-15107
An issue was discovered in Webmin through 1.920. The parameter old in password_change.cgi...
An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.
- Record
CVE-2019-15107- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List
9.8
An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.
- Record
CVE-2019-15107- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2019-6178
9.8
An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.
- Record
EUVD-2019-6178- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-69hp-hrv4-rxrr
9.8
An issue was discovered in Webmin through 1.920. The parameter old in password_change.cgi...
An issue was discovered in Webmin through 1.920. The parameter old in password_change.cgi contains a command injection vulnerability.
- Record
GHSA-69hp-hrv4-rxrr- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
CISA KEV No score
Webmin Command Injection Vulnerability
An issue was discovered in Webmin. The parameter old in password_change.cgi contains a command injection vulnerability.
- Record
CVE-2019-15107- Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
9.8
An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.
- Record
CVE-2019-15107- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2019-0237 No score
Updated webmin packages fix security vulnerability
Updated webmin package fixes security vulnerability:
Webmin before 1.930 allows remote exploits if the option to change expired passwords is enabled (CVE-2019-15107).
Note that it is only vulnerable if changing of expired passwords is enabled, which is not the case by default.
- Record
MGASA-2019-0237- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
webminMageia:7 |
before 1.930-1.mga7 | 1.930-1.mga7 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Metasploit | Webmin password_change.cgi Backdoor | 2019-08-10 |
| Exploit-DB | Webmin 1.920 - Unauthenticated Remote Code Execution (Metasploit) | 2019-08-12 |
| Exploit-DB | Webmin 1.920 - Remote Code Execution | 2019-08-19 |
| PoC in GitHub | jas502n/CVE-2019-15107 | 2019-08-19 |
| PoC in GitHub | HACHp1/webmin_docker_and_exp | 2019-08-22 |
| PoC in GitHub | ketlerd/CVE-2019-15107 | 2019-08-22 |
| PoC in GitHub | AdministratorGithub/CVE-2019-15107 | 2019-08-23 |
| PoC in GitHub | Rayferrufino/Make-and-Break | 2019-09-23 |
| PoC in GitHub | AleWong/WebminRCE-EXP-CVE-2019-15107- | 2019-10-24 |
| PoC in GitHub | ianxtianxt/CVE-2019-15107 | 2019-12-15 |
Show 19 moreShow less
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | hannob/webminex | 2019-12-25 |
| PoC in GitHub | ch4ko/webmin_CVE-2019-15107 | 2019-12-29 |
| PoC in GitHub | cdedmondson/Modified-CVE-2019-15107 | 2020-06-20 |
| PoC in GitHub | ruthvikvegunta/CVE-2019-15107 | 2020-08-08 |
| PoC in GitHub | n0obit4/Webmin_1.890-POC | 2020-09-13 |
| PoC in GitHub | squid22/Webmin_CVE-2019-15107 | 2020-10-15 |
| PoC in GitHub | MuirlandOracle/CVE-2019-15107 | 2020-11-09 |
| PoC in GitHub | diegojuan/CVE-2019-15107 | 2020-12-03 |
| PoC in GitHub | whokilleddb/CVE-2019-15107 | 2021-07-02 |
| PoC in GitHub | darrenmartyn/CVE-2019-15107 | 2021-09-09 |
| PoC in GitHub | hacknotes/CVE-2019-15107-Exploit | 2021-10-05 |
| PoC in GitHub | CyberTuz/CVE-2019-15107_detection | 2021-10-10 |
| PoC in GitHub | hadrian3689/webmin_1.920 | 2022-02-21 |
| PoC in GitHub | f0rkr/CVE-2019-15107 | 2022-04-18 |
| PoC in GitHub | psw01/CVE-2019-15107_webminRCE | 2022-06-17 |
| PoC in GitHub | TheAlpha19/MiniExploit | 2022-07-26 |
| PoC in GitHub | wenruoya/CVE-2019-15107 | 2023-03-09 |
| PoC in GitHub | g1vi/CVE-2019-15107 | 2023-03-31 |
| Nuclei | Webmin <= 1.920 - Unauthenticated Remote Command Execution |
Plus 17 more. The full list has every link.
History
| Recorded | Changed | Sources |
|---|---|---|
| exploitation | ||
| exploits, exploits_more | ||
| exploits | ||
| first indexed | CVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, Nuclei, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-15107 is a critical vulnerability (CVSS 9.8) in Webmin, published August 16, 2019. CISA lists it as known to be exploited, since March 25, 2022. EUVD reports exploitation since March 25, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 99.7%, the 99th percentile. Fixed in webmin 1.930-1.mga7.
References
webmin.com/security.html
exploit-db.com/exploits/47230
pentest.com.tr/exploits/DEFCON-Webmin-1920-Unauthenticated-Remote-Command-Execution.html
packetstormsecurity.com/files/154141/Webmin-Remote-Comman-Execution.html
packetstormsecurity.com/files/154141/Webmin-1.920-Remote-Command-Execution.html
packetstormsecurity.com/files/154197/Webmin-1.920-password_change.cgi-Backdoor.html
Show 8 moreShow less
packetstormsecurity.com/files/154485/Webmin-1.920-Remote-Code-Execution.html
attackerkb.com/topics/hxx3zmiCkR/webmin-password-change-cgi-command-injection
cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-15107
nvd.nist.gov/vuln/detail/CVE-2019-15107
github.com/advisories/GHSA-69hp-hrv4-rxrr
advisories.mageia.org/MGASA-2019-0237.html
bugs.mageia.org/show_bug.cgi?id=25331
webmin.com/changes.html