CVE-2019-5087
An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the...
An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools 1.0.7. An integer overflow can occur while calculating the row's allocation size, that could be exploited to corrupt memory and eventually execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools 1.0.7. An integer overflow can occur while calculating the row's allocation size, that could be exploited to corrupt memory and eventually execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.
- Record
CVE-2019-5087- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-680
- Updated
- 2026-11-02
EUVDEUVD-2019-14692
8.8
An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools 1.0.7. An integer overflow can occur while calculating the row's allocation size, that could be exploited to corrupt memory and eventually execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.
- Record
EUVD-2019-14692- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3768-p22h-mhp7
8.8
An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the...
An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools 1.0.7. An integer overflow can occur while calculating the row's allocation size, that could be exploited to corrupt memory and eventually execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.
- Record
GHSA-3768-p22h-mhp7- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-190, CWE-787
- Updated
- 2026-11-02
NVD
8.8
An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools 1.0.7. An integer overflow can occur while calculating the row's allocation size, that could be exploited to corrupt memory and eventually execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.
- Record
CVE-2019-5087- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-680, CWE-190, CWE-787
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-5087
8.8
An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools 1.0.7. An integer overflow can occur while calculating the row's allocation size, that could be exploited to corrupt memory and eventually execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.
- Record
UBUNTU-CVE-2019-5087- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-5988-1 No score
xcftools vulnerabilities
It was discovered that integer overflows vulnerabilities existed in Xcftools. An attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2019-5086, CVE-2019-5087)
- Record
USN-5988-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xcftoolsDebian:9 From an advisory covering 2 CVEs |
before 1.0.7-6+deb9u1, plus listed versions 1.0.7-6 |
1.0.7-6+deb9u1 |
xcftoolsUbuntu:Pro:16.04:LTS |
before 1.0.7-5ubuntu0.1~esm1, plus listed versions 1.0.7-4ubuntu11.0.7-5 |
1.0.7-5ubuntu0.1~esm1 |
xcftoolsUbuntu:18.04:LTS |
before 1.0.7-6ubuntu0.1, plus listed versions 1.0.7-6 |
1.0.7-6ubuntu0.1 |
xcftoolsUbuntu:20.04:LTS |
before 1.0.7-6ubuntu0.20.04.1, plus listed versions 1.0.7-61.0.7-6build1 |
1.0.7-6ubuntu0.20.04.1 |
xcftoolsUbuntu:Pro:16.04:LTS From an advisory covering 2 CVEs |
before 1.0.7-5ubuntu0.1~esm1, plus listed versions 1.0.7-4ubuntu11.0.7-5 |
1.0.7-5ubuntu0.1~esm1 |
xcftoolsUbuntu:18.04:LTS From an advisory covering 2 CVEs |
before 1.0.7-6ubuntu0.1, plus listed versions 1.0.7-6 |
1.0.7-6ubuntu0.1 |
xcftoolsUbuntu:20.04:LTS From an advisory covering 2 CVEs |
before 1.0.7-6ubuntu0.20.04.1, plus listed versions 1.0.7-61.0.7-6build1 |
1.0.7-6ubuntu0.20.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-5087 is a high vulnerability (CVSS 8.8) in Xcftools Project Xcftools, published November 21, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.64%, the 89th percentile. Fixed in xcftools 1.0.7-5ubuntu0.1~esm1.
References
lists.debian.org/debian-lts-announce/2021/02/msg00014.html
lists.debian.org/debian-lts-announce/2021/03/msg00008.html
talosintelligence.com/vulnerability_reports/TALOS-2019-0879
nvd.nist.gov/vuln/detail/CVE-2019-5087
github.com/advisories/GHSA-3768-p22h-mhp7
ubuntu.com/security/CVE-2019-5087
ubuntu.com/security/notices/USN-5988-1
cve.org/CVERecord?id=CVE-2019-5087
ubuntu.com/security/CVE-2019-5086