Every CVE Search/ Get API key

CVE-2019-5086

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the...

7.5 HighFix available

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools, version 1.0.7. An integer overflow can occur while walking through tiles that could be exploited to corrupt memory and execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.15%Up 1.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.5

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools, version 1.0.7. An integer overflow can occur while walking through tiles that could be exploited to corrupt memory and execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.

Record
CVE-2019-5086
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-680
Updated
2026-11-02
EUVDEUVD-2019-14691 7.5

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools, version 1.0.7. An integer overflow can occur while walking through tiles that could be exploited to corrupt memory and execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.

Record
EUVD-2019-14691
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-j44m-w6x3-678v 8.8

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the...

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools, version 1.0.7. An integer overflow can occur while walking through tiles that could be exploited to corrupt memory and execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.

Record
GHSA-j44m-w6x3-678v
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-190, CWE-787
Updated
2026-11-02
NVD 8.8

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools, version 1.0.7. An integer overflow can occur while walking through tiles that could be exploited to corrupt memory and execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.

Record
CVE-2019-5086
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-680, CWE-190, CWE-787
Updated
2026-11-02
OSVUBUNTU-CVE-2019-5086 8.8

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools, version 1.0.7. An integer overflow can occur while walking through tiles that could be exploited to corrupt memory and execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.

Record
UBUNTU-CVE-2019-5086
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-5988-1 No score

xcftools vulnerabilities

It was discovered that integer overflows vulnerabilities existed in Xcftools. An attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2019-5086, CVE-2019-5087)

Record
USN-5988-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xcftools
Debian:9
From an advisory covering 2 CVEs
before 1.0.7-6+deb9u1, plus listed versions
1.0.7-6
1.0.7-6+deb9u1
xcftools
Ubuntu:Pro:16.04:LTS
before 1.0.7-5ubuntu0.1~esm1, plus listed versions
1.0.7-4ubuntu11.0.7-5
1.0.7-5ubuntu0.1~esm1
xcftools
Ubuntu:18.04:LTS
before 1.0.7-6ubuntu0.1, plus listed versions
1.0.7-6
1.0.7-6ubuntu0.1
xcftools
Ubuntu:20.04:LTS
before 1.0.7-6ubuntu0.20.04.1, plus listed versions
1.0.7-61.0.7-6build1
1.0.7-6ubuntu0.20.04.1
xcftools
Ubuntu:Pro:16.04:LTS
From an advisory covering 2 CVEs
before 1.0.7-5ubuntu0.1~esm1, plus listed versions
1.0.7-4ubuntu11.0.7-5
1.0.7-5ubuntu0.1~esm1
xcftools
Ubuntu:18.04:LTS
From an advisory covering 2 CVEs
before 1.0.7-6ubuntu0.1, plus listed versions
1.0.7-6
1.0.7-6ubuntu0.1
xcftools
Ubuntu:20.04:LTS
From an advisory covering 2 CVEs
before 1.0.7-6ubuntu0.20.04.1, plus listed versions
1.0.7-61.0.7-6build1
1.0.7-6ubuntu0.20.04.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-5086 is a high vulnerability (CVSS 7.5) in Xcftools Project Xcftools, published November 21, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.15%, the 88th percentile. Fixed in xcftools 1.0.7-5ubuntu0.1~esm1.

References

MoveEnter Open