Every CVE Search/ Get API key

CVE-2019-8942

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an...

8.8 HighPublic exploitFix available

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

82.7%Up 21.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Record
CVE-2019-8942
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-434
Updated
2026-11-02
CVE List No score

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Record
CVE-2019-8942
Updated
2026-11-02
EUVDEUVD-2019-18329 No score

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Record
EUVD-2019-18329
Updated
2026-11-03
GitHub AdvisoriesGHSA-rwhm-6hw4-9fgg 8.8

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an...

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Record
GHSA-rwhm-6hw4-9fgg
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-434
Updated
2026-11-02
OSV 8.8

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Record
CVE-2019-8942
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-8942 8.8

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Record
DEBIAN-CVE-2019-8942
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-8942 8.8

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Record
UBUNTU-CVE-2019-8942
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 5.0.1+dfsg1-1
5.0.1+dfsg1-1
wordpress
Debian:13
before 5.0.1+dfsg1-1
5.0.1+dfsg1-1
wordpress
Debian:14
before 5.0.1+dfsg1-1
5.0.1+dfsg1-1
wordpress
Debian:8
From an advisory covering 2 CVEs
before 4.1.26+dfsg-1+deb8u1, plus listed versions
4.1+dfsg-14.1+dfsg-1+deb8u14.1+dfsg-1+deb8u104.1+dfsg-1+deb8u114.1+dfsg-1+deb8u12
Show 16 moreShow less
4.1+dfsg-1+deb8u134.1+dfsg-1+deb8u144.1+dfsg-1+deb8u154.1+dfsg-1+deb8u164.1+dfsg-1+deb8u174.1+dfsg-1+deb8u184.1+dfsg-1+deb8u24.1+dfsg-1+deb8u34.1+dfsg-1+deb8u44.1+dfsg-1+deb8u54.1+dfsg-1+deb8u64.1+dfsg-1+deb8u74.1+dfsg-1+deb8u84.1+dfsg-1+deb8u94.1.1+dfsg-14.1.25+dfsg-1+deb8u1
4.1.26+dfsg-1+deb8u1
wordpress
Debian:9
From an advisory covering 8 CVEs
before 4.7.5+dfsg-2+deb9u5, plus listed versions
4.7.5+dfsg-24.7.5+dfsg-2+deb9u14.7.5+dfsg-2+deb9u1~bpo8+14.7.5+dfsg-2+deb9u24.7.5+dfsg-2+deb9u2~bpo8+14.7.5+dfsg-2+deb9u34.7.5+dfsg-2+deb9u4
4.7.5+dfsg-2+deb9u5
wordpress
Ubuntu:16.04:LTS
All versions, plus listed versions
4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1
None known
wordpress
Ubuntu:18.04:LTS
All versions, plus listed versions
4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
MetasploitWordPress Crop-image Shell Upload2019-02-19
PoC in GitHubbrianwrf/WordPress_4.9.8_RCE_POC2019-02-25
Exploit-DBWordPress Core 5.0 - Remote Code Execution2019-03-01
Exploit-DBWordPress Core 5.0.0 - Crop-image Shell Upload (Metasploit)2019-04-05
PoC in GitHubsynacktiv/CVE-2019-89422019-05-02
PoC in GitHubsynod2/WP_CROP_RCE2021-05-05
PoC in GitHubtuannq2299/CVE-2019-89422022-05-31
PoC in GitHubSpeatX/WordPress-RCE-CVE-2019-89422026-05-22

History

History
RecordedChangedSources
affected, exploits, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-8942 is a high vulnerability (CVSS 8.8) in Wordpress, published February 20, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 82.7%, the 99th percentile. Fixed in wordpress 5.0.1+dfsg1-1.

References

Show 8 moreShow less
MoveEnter Open