CVE-2019-8942
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an...
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
- Record
CVE-2019-8942- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-434
- Updated
- 2026-11-02
CVE List No score
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
- Record
CVE-2019-8942- Updated
- 2026-11-02
EUVDEUVD-2019-18329 No score
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
- Record
EUVD-2019-18329- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rwhm-6hw4-9fgg
8.8
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an...
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
- Record
GHSA-rwhm-6hw4-9fgg- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-434
- Updated
- 2026-11-02
OSV
8.8
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
- Record
CVE-2019-8942- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-8942
8.8
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
- Record
DEBIAN-CVE-2019-8942- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-8942
8.8
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
- Record
UBUNTU-CVE-2019-8942- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 5.0.1+dfsg1-1 | 5.0.1+dfsg1-1 |
wordpressDebian:13 |
before 5.0.1+dfsg1-1 | 5.0.1+dfsg1-1 |
wordpressDebian:14 |
before 5.0.1+dfsg1-1 | 5.0.1+dfsg1-1 |
wordpressDebian:8 From an advisory covering 2 CVEs |
before 4.1.26+dfsg-1+deb8u1, plus listed versions 4.1+dfsg-14.1+dfsg-1+deb8u14.1+dfsg-1+deb8u104.1+dfsg-1+deb8u114.1+dfsg-1+deb8u12 Show 16 moreShow less4.1+dfsg-1+deb8u134.1+dfsg-1+deb8u144.1+dfsg-1+deb8u154.1+dfsg-1+deb8u164.1+dfsg-1+deb8u174.1+dfsg-1+deb8u184.1+dfsg-1+deb8u24.1+dfsg-1+deb8u34.1+dfsg-1+deb8u44.1+dfsg-1+deb8u54.1+dfsg-1+deb8u64.1+dfsg-1+deb8u74.1+dfsg-1+deb8u84.1+dfsg-1+deb8u94.1.1+dfsg-14.1.25+dfsg-1+deb8u1 |
4.1.26+dfsg-1+deb8u1 |
wordpressDebian:9 From an advisory covering 8 CVEs |
before 4.7.5+dfsg-2+deb9u5, plus listed versions 4.7.5+dfsg-24.7.5+dfsg-2+deb9u14.7.5+dfsg-2+deb9u1~bpo8+14.7.5+dfsg-2+deb9u24.7.5+dfsg-2+deb9u2~bpo8+14.7.5+dfsg-2+deb9u34.7.5+dfsg-2+deb9u4 |
4.7.5+dfsg-2+deb9u5 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
wordpressUbuntu:18.04:LTS |
All versions, plus listed versions 4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Metasploit | WordPress Crop-image Shell Upload | 2019-02-19 |
| PoC in GitHub | brianwrf/WordPress_4.9.8_RCE_POC | 2019-02-25 |
| Exploit-DB | WordPress Core 5.0 - Remote Code Execution | 2019-03-01 |
| Exploit-DB | WordPress Core 5.0.0 - Crop-image Shell Upload (Metasploit) | 2019-04-05 |
| PoC in GitHub | synacktiv/CVE-2019-8942 | 2019-05-02 |
| PoC in GitHub | synod2/WP_CROP_RCE | 2021-05-05 |
| PoC in GitHub | tuannq2299/CVE-2019-8942 | 2022-05-31 |
| PoC in GitHub | SpeatX/WordPress-RCE-CVE-2019-8942 | 2026-05-22 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, exploits, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-8942 is a high vulnerability (CVSS 8.8) in Wordpress, published February 20, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 82.7%, the 99th percentile. Fixed in wordpress 5.0.1+dfsg1-1.
References
wpvulndb.com/vulnerabilities/9222
exploit-db.com/exploits/46511
securityfocus.com/bid/107088
blog.ripstech.com/2019/wordpress-image-remote-code-execution
debian.org/security/2019/dsa-4401
lists.debian.org/debian-lts-announce/2019/03/msg00044.html
Show 8 moreShow less
packetstormsecurity.com/files/152396/WordPress-5.0.0-crop-image-Shell-Upload.html
rapid7.com/db/modules/exploit/multi/http/wp_crop_rce
exploit-db.com/exploits/46662
nvd.nist.gov/vuln/detail/CVE-2019-8942
github.com/advisories/GHSA-rwhm-6hw4-9fgg
security-tracker.debian.org/tracker/CVE-2019-8942
ubuntu.com/security/CVE-2019-8942
cve.org/CVERecord?id=CVE-2019-8942