Every CVE Search/ Get API key

CVE-2020-3810

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result...

5.5 MediumFix available

CVE-2020-3810 is a medium vulnerability (CVSS 5.5) in Debian Apt, published May 12, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.34%, the 71st percentile. Fixed in apt 2.1.2.

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.34%Down 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

Record
CVE-2020-3810
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-20, CWE-125
Updated
2026-11-02
CVE List No score

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

Record
CVE-2020-3810
Updated
2026-11-02
EUVDEUVD-2020-25075 No score

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

Record
EUVD-2020-25075
Updated
2026-11-03
GitHub AdvisoriesGHSA-q2xq-8h7m-vrfm 5.5

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result...

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

Record
GHSA-q2xq-8h7m-vrfm
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 5.5

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

Record
CVE-2020-3810
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-3810 5.5

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

Record
DEBIAN-CVE-2020-3810
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-3810 5.5

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

Record
UBUNTU-CVE-2020-3810
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-4359-1 No score

apt vulnerability

It was discovered that APT incorrectly handled certain filenames during package installation. If an attacker could provide a specially crafted package to be installed by the system administrator, this could cause APT to crash.

Record
USN-4359-1
Updated
2026-11-02
OSVUSN-4359-2 No score

apt vulnerability

USN-4359-1 fixed a vulnerability in APT. This update provides the corresponding update for Ubuntu 12.04 ESM and 14.04 ESM.

Original advisory details:

It was discovered that APT incorrectly handled certain filenames during package installation. If an attacker could provide a specially crafted package to be installed by the system administrator, this could cause APT to crash.

Record
USN-4359-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apt
Debian:12
before 2.1.2
2.1.2
apt
Debian:13
before 2.1.2
2.1.2
apt
Debian:14
before 2.1.2
2.1.2
apt
Debian:8
before 1.0.9.8.6, plus listed versions
1.0.9.81.0.9.8.11.0.9.8.21.0.9.8.31.0.9.8.41.0.9.8.5
1.0.9.8.6
apt
Debian:9
before 1.4.10, plus listed versions
1.4.61.4.71.4.81.4.9
1.4.10
apt
Debian:10
before 1.8.2.1, plus listed versions
1.8.2
1.8.2.1
apt
Ubuntu:Pro:14.04:LTS
before 1.0.1ubuntu2.24+esm1, plus listed versions
0.9.9.1~ubuntu30.9.9.1~ubuntu40.9.9.1~ubuntu50.9.13~exp1ubuntu10.9.13~exp1ubuntu2
Show 32 moreShow less
0.9.13~exp1ubuntu30.9.13.1~ubuntu10.9.14.1ubuntu10.9.14.1ubuntu20.9.15.1ubuntu10.9.15.4ubuntu10.9.15.4ubuntu20.9.15.4ubuntu30.9.15.4ubuntu40.9.15.4ubuntu51.0.1ubuntu21.0.1ubuntu2.11.0.1ubuntu2.31.0.1ubuntu2.4.11.0.1ubuntu2.51.0.1ubuntu2.61.0.1ubuntu2.71.0.1ubuntu2.81.0.1ubuntu2.91.0.1ubuntu2.101.0.1ubuntu2.111.0.1ubuntu2.121.0.1ubuntu2.131.0.1ubuntu2.141.0.1ubuntu2.151.0.1ubuntu2.171.0.1ubuntu2.181.0.1ubuntu2.191.0.1ubuntu2.201.0.1ubuntu2.221.0.1ubuntu2.231.0.1ubuntu2.24
1.0.1ubuntu2.24+esm1
apt
Ubuntu:16.04:LTS
before 1.2.32ubuntu0.1, plus listed versions
1.0.10.2ubuntu11.1.41.1.51.1.101.2.3
Show 21 moreShow less
1.2.41.2.61.2.71.2.81.2.91.2.101.2.10ubuntu11.2.12~ubuntu16.04.11.2.151.2.15ubuntu0.21.2.181.2.191.2.201.2.241.2.251.2.261.2.271.2.291.2.29ubuntu0.11.2.311.2.32
1.2.32ubuntu0.1
apt
Ubuntu:18.04:LTS
before 1.6.12ubuntu0.1, plus listed versions
1.51.5.11.6~alpha51.6~alpha7ubuntu11.6~alpha7ubuntu2
Show 13 moreShow less
1.6~beta11.6~rc11.61.6.11.6.21.6.31.6.3ubuntu0.11.6.61.6.6ubuntu0.11.6.81.6.101.6.111.6.12
1.6.12ubuntu0.1
apt
Ubuntu:20.04:LTS
before 2.0.2ubuntu0.1, plus listed versions
1.9.41.9.51.9.71.9.81.9.9
Show 5 moreShow less
1.9.102.0.02.0.12.0.1ubuntu12.0.2
2.0.2ubuntu0.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 12 moreShow less
MoveEnter Open