apt vulnerabilities (Debian)
22 vulnerabilities.
-
aptDebian apt integer wraparound 5.7 Medium -
aptDebian Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result... 5.5 Medium -
aptDebian It was found that apt-key in apt, all versions, do not correctly validate gpg keys with the... 3.7 Low -
aptDebian Incorrect sanitation of the 302 redirect field in HTTP transport method of apt versions 1.4.8 and... 8.1 High -
aptDebian The mirror:// method implementation in Advanced Package Tool (APT) 1.6.x before 1.6.4 and 1.7.x... 5.9 Medium -
aptDebian The apt package in Debian jessie before 1.0.9.8.4, in Debian unstable before 1.4~beta2, in Ubuntu... 5.9 Medium -
aptDebian The changelog command in Apt before 1.0.9.2 allows local users to write to arbitrary files via a... 3.6 Low -
aptDebian Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the... 6.8 Medium -
aptDebian The apt-get download command in APT before 1.0.9 does not properly validate signatures for... 7.5 High -
aptDebian APT before 1.0.9, when the Acquire::GzipIndexes option is enabled, does not validate checksums,... 7.5 High -
aptDebian APT before 1.0.9 does not "invalidate repository data" when moving from an unauthenticated to... 6.8 Medium -
aptDebian APT before 1.0.9 does not verify downloaded files if they have been modified as indicated using... 7.5 High -
aptDebian APT before 1.0.4 does not properly validate source packages, which allows man-in-the-middle... 4.0 Medium -
aptDebian The pkgAcqMetaClearSig::Failed method in apt-pkg/acquire-item.cc in Advanced Package Tool (APT) 0... 4.3 Medium -
aptDebian methods/https.cc in apt before 0.8.11 accepts connections when the certificate host name fails... 2.6 Low -
aptDebian apt 0.8.16, 0.9.7, and possibly other versions does not properly handle InRelease files, which... 4.3 Medium -
aptDebian Apt 0.8.16~exp5ubuntu13.x before 0.8.16~exp5ubuntu13.6, 0.8.16~exp12ubuntu10.x before 0.8.16... 2.1 Low -
aptDebian APT 0.7.x before 0.7.25 and 0.8.x before 0.8.16, when using the apt-key net-update to import... 2.6 Low -
aptDebian APT 0.7.x before 0.7.25 and 0.8.x before 0.8.16, when using the apt-key net-update to import... 2.6 Low -
aptDebian APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the... 4.3 Medium -
aptDebian apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes... 10.0 High -
aptDebian apt 0.7.20 does not check when the date command returns an "invalid date" error, which can... 10.0 High