CVE-2020-8124
Improper Validation and Sanitization in url-parse
CVE-2020-8124 is a medium vulnerability (CVSS 5.3) in Hackerone Url-parse, published February 4, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.65%, the 76th percentile. Fixed in url-parse 1.4.5.
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
- Record
CVE-2020-8124- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
- Record
CVE-2020-8124- Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2022-0441 No score
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
- Record
EUVD-2022-0441- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-46c4-8wrp-j99v
5.3
Improper Validation and Sanitization in url-parse
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
- Record
GHSA-46c4-8wrp-j99v- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
5.3
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
- Record
CVE-2020-8124- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-8124
5.3
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
- Record
DEBIAN-CVE-2020-8124- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-46c4-8wrp-j99v
5.3
Improper Validation and Sanitization in url-parse
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
- Record
GHSA-46c4-8wrp-j99v- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVRHSA-2020:0972
7.0
Red Hat Security Advisory: Red Hat OpenShift Service Mesh 1.0.10 Jaeger and Kiali security update
- Record
RHSA-2020:0972- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-8124
5.3
Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
- Record
UBUNTU-CVE-2020-8124- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVUSN-5973-1 No score
node-url-parse vulnerabilities
It was discovered that url-parse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to cause a denial of service, or to perform a server-side request forgery attack or open redirect attack. (CVE-2018-3774)
It was discovered that url-parse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to bypass input validation. This issue was only fixed in Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-8124)
Yaniv Nizry discovered that url-parse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to cause a denial of service, or to perform a server-side request forgery attack or open redirect attack. This issue was only fixed in Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-27515)
It was discovered that url-parse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to cause a denial of service, or to perform a server-side request forgery attack or open redirect attack. This issue was only fixed in Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-3664)
It was discovered that url-parse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to bypass authorization. This issue was only fixed in Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2022-0512, CVE-2022-0639, CVE-2022-0691)
Rohan Sharma discovered that url-parse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to bypass authorization. This issue was only fixed in Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2022-0686)
- Record
USN-5973-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
url-parsenpm |
0.1.0 up to 1.4.5 | 1.4.5 |
node-url-parseDebian:12 |
before 1.4.7-1 | 1.4.7-1 |
node-url-parseDebian:13 |
before 1.4.7-1 | 1.4.7-1 |
node-url-parseDebian:14 |
before 1.4.7-1 | 1.4.7-1 |
jaegerRed Hat:service_mesh:1.0::el7 |
before 0:v1.13.1.redhat6-1.el7 | 0:v1.13.1.redhat6-1.el7 |
kialiRed Hat:service_mesh:1.0::el7 |
before 0:v1.0.10.redhat1-1.el7 | 0:v1.0.10.redhat1-1.el7 |
node-url-parseUbuntu:Pro:16.04:LTS |
before 1.0.5-2ubuntu0.1~esm2, plus listed versions 1.0.5-11.0.5-2 |
1.0.5-2ubuntu0.1~esm2 |
node-url-parseUbuntu:18.04:LTS |
before 1.2.0-1ubuntu0.1, plus listed versions 1.0.5-21.2.0-1 |
1.2.0-1ubuntu0.1 |
node-url-parseUbuntu:20.04:LTS |
before 1.4.7-3ubuntu0.1, plus listed versions 1.4.7-3 |
1.4.7-3ubuntu0.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases, products | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
hackerone.com/reports/496293
nvd.nist.gov/vuln/detail/CVE-2020-8124
github.com/github/advisory-database/pull/6762
github.com/unshiftio/url-parse/commit/3ecd256f127c3ada36a84d9b8dd3ebd14316274b
github.com/advisories/GHSA-46c4-8wrp-j99v
security-tracker.debian.org/tracker/CVE-2020-8124
Show 21 moreShow less
github.com/unshiftio/url-parse
access.redhat.com/errata/RHSA-2020:0972
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1800774
security.access.redhat.com/data/csaf/v2/advisories/2020/rhsa-2020_0972.json
access.redhat.com/security/cve/CVE-2020-1762
bugzilla.redhat.com/show_bug.cgi?id=1810387
cve.org/CVERecord?id=CVE-2020-1762
nvd.nist.gov/vuln/detail/CVE-2020-1762
kiali.io/news/security-bulletins/kiali-security-001
access.redhat.com/security/cve/CVE-2020-8124
cve.org/CVERecord?id=CVE-2020-8124
ubuntu.com/security/CVE-2020-8124
ubuntu.com/security/notices/USN-5973-1
ubuntu.com/security/CVE-2018-3774
ubuntu.com/security/CVE-2021-3664
ubuntu.com/security/CVE-2021-27515
ubuntu.com/security/CVE-2022-0512
ubuntu.com/security/CVE-2022-0639
ubuntu.com/security/CVE-2022-0686
ubuntu.com/security/CVE-2022-0691