CVE-2020-1762
Insufficient Session Expiration in Kiali
CVE-2020-1762 is a high vulnerability (CVSS 7.0) in [kiali] Kiali, published April 27, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 67th percentile. Fixed in github.com/kiali/kiali 1.15.1.
An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.0
An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.
- Record
CVE-2020-1762- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-613, CWE-384
- Updated
- 2026-11-02
EUVDEUVD-2021-0930
7.0
An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.
- Record
EUVD-2021-0930- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-465w-gg5p-85c9
8.6
Insufficient Session Expiration in Kiali
An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.
- Record
GHSA-465w-gg5p-85c9- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-295, CWE-384, CWE-613
- Updated
- 2026-11-02
NVD
7.0
An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.
- Record
CVE-2020-1762- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-384, CWE-613
- Updated
- 2026-11-02
OSV
8.6
An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.
- Record
CVE-2020-1762- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Updated
- 2026-11-02
OSVGHSA-465w-gg5p-85c9
8.6
Insufficient Session Expiration in Kiali
An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.
- Record
GHSA-465w-gg5p-85c9- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-295, CWE-384, CWE-613
- Updated
- 2026-11-02
OSVRHSA-2020:0972
7.0
Red Hat Security Advisory: Red Hat OpenShift Service Mesh 1.0.10 Jaeger and Kiali security update
- Record
RHSA-2020:0972- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Updated
- 2026-11-02
OSVGO-2022-0626 No score
Insufficient Session Expiration in Kiali in github.com/kiali/kiali
Insufficient Session Expiration in Kiali in github.com/kiali/kiali
- Record
GO-2022-0626- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/kiali/kialiGo |
0.4.0 up to 1.15.1 | 1.15.1 |
jaegerRed Hat:service_mesh:1.0::el7 |
before 0:v1.13.1.redhat6-1.el7 | 0:v1.13.1.redhat6-1.el7 |
kialiRed Hat:service_mesh:1.0::el7 |
before 0:v1.0.10.redhat1-1.el7 | 0:v1.0.10.redhat1-1.el7 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases, products | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
kiali.io/news/security-bulletins/kiali-security-001
bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1762
nvd.nist.gov/vuln/detail/CVE-2020-1762
github.com/kiali/kiali/commit/93f5cd0b6698e8fe8772afb8f35816f6c086aef1
github.com/kiali/kiali/commit/c91a0949683976f621cca213c1193831d63b381c
bugzilla.redhat.com/show_bug.cgi?id=1810387
Show 10 moreShow less
github.com/advisories/GHSA-465w-gg5p-85c9
access.redhat.com/errata/RHSA-2020:0972
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1800774
security.access.redhat.com/data/csaf/v2/advisories/2020/rhsa-2020_0972.json
access.redhat.com/security/cve/CVE-2020-1762
cve.org/CVERecord?id=CVE-2020-1762
access.redhat.com/security/cve/CVE-2020-8124
cve.org/CVERecord?id=CVE-2020-8124
nvd.nist.gov/vuln/detail/CVE-2020-8124