CVE-2021-33564
Dragonfly contains remote code execution vulnerability
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
- Record
CVE-2021-33564- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-88
- Updated
- 2026-11-02
CVE List No score
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
- Record
CVE-2021-33564- Updated
- 2026-11-02
EUVDEUVD-2021-1341 No score
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
- Record
EUVD-2021-1341- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j858-xp5v-f8xx
9.8
Dragonfly contains remote code execution vulnerability
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
- Record
GHSA-j858-xp5v-f8xx- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-88, CWE-94
- Updated
- 2026-11-02
OSV
9.8
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
- Record
CVE-2021-33564- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-j858-xp5v-f8xx
9.8
Dragonfly contains remote code execution vulnerability
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
- Record
GHSA-j858-xp5v-f8xx- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-88, CWE-94
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dragonflyRubyGems |
before 1.4.0 | 1.4.0 |
dragonflyRubyGems |
before 1.4.0, plus listed versions 0.1.00.1.10.1.40.1.50.1.6 Show 45 moreShow less0.2.10.3.00.3.20.3.30.3.40.3.50.3.60.3.70.3.80.4.00.4.10.4.20.4.30.4.40.5.00.5.10.5.20.5.30.5.40.5.50.5.60.5.70.6.00.6.10.6.20.7.00.7.10.7.20.7.30.7.40.7.50.7.60.7.70.8.00.8.10.8.20.8.40.8.50.8.60.9.00.9.10.9.100.9.110.9.120.9.13 |
1.4.0 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | Ruby Dragonfly <1.4.0 - Remote Code Execution | |
| PoC in GitHub | dorkerdevil/CVE-2021-33564 | 2021-05-27 |
| PoC in GitHub | mlr0p/CVE-2021-33564 | 2021-05-25 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-33564 is a critical vulnerability (CVSS 9.8) in Dragonfly Project Dragonfly, published May 29, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 72.1%, the 99th percentile. Fixed in dragonfly 1.4.0.
References
github.com/markevans/dragonfly/issues/513
github.com/markevans/dragonfly/commit/25399297bb457f7fcf8e3f91e85945b255b111b5
github.com/markevans/dragonfly/compare/v1.3.0...v1.4.0
raw.githubusercontent.com/projectdiscovery/nuclei-templates/master/cves/2021/CVE-2021-33564.yaml
github.com/mlr0p/CVE-2021-33564
zxsecurity.co.nz/research/argunment-injection-ruby-dragonfly
nvd.nist.gov/vuln/detail/CVE-2021-33564
github.com/advisories/GHSA-j858-xp5v-f8xx
github.com/rubysec/ruby-advisory-db/blob/master/gems/dragonfly/CVE-2021-33564.yml
Left out here: 30 versions. The JSON record has them.