CVE-2022-28959
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web...
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
- Record
CVE-2022-28959- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
- Record
CVE-2022-28959- Updated
- 2026-11-02
EUVDEUVD-2022-33391 No score
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
- Record
EUVD-2022-33391- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hq48-7c77-c44g
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web...
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
- Record
GHSA-hq48-7c77-c44g- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
- Record
CVE-2022-28959- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-28959
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
- Record
DEBIAN-CVE-2022-28959- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-28959
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
- Record
UBUNTU-CVE-2022-28959- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUSN-7318-1 No score
spip vulnerabilities
It was discovered that svg-sanitizer, vendored in SPIP, did not properly sanitize SVG/XML content. An attacker could possibly use this issue to perform cross site scripting. This issue only affected Ubuntu 24.10. (CVE-2022-23638)
It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform cross site scripting. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28959)
It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform PHP injection attacks. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28960)
It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28961)
It was discovered that SPIP did not properly sanitize certain inputs. A remote authenticated attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-37155)
It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2023-24258)
It was discovered that SPIP did not properly handle serialization under certain circumstances. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2023-27372)
It was discovered that SPIP did not properly sanitize HTTP requests. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2024-8517)
- Record
USN-7318-1- Updated
- 2026-11-02
OSVUSN-8150-1 No score
spip vulnerabilities
It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform cross site scripting. (CVE-2022-28959)
It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform PHP injection attacks. (CVE-2022-28960)
It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform SQL injection attacks. (CVE-2022-28961)
- Record
USN-8150-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
spipDebian:13 |
before 3.2.8-1 | 3.2.8-1 |
spipDebian:14 |
before 3.2.8-1 | 3.2.8-1 |
spipDebian:10 |
before 3.2.4-1+deb10u3, plus listed versions 3.2.4-13.2.4-1+deb10u13.2.4-1+deb10u2 |
3.2.4-1+deb10u3 |
spipUbuntu:Pro:16.04:LTS |
before 3.0.21-1ubuntu1+esm1, plus listed versions 3.0.20-13.0.21-13.0.21-1ubuntu1 |
3.0.21-1ubuntu1+esm1 |
spipUbuntu:Pro:18.04:LTS |
before 3.1.4-4~deb9u5ubuntu0.1~esm2, plus listed versions 3.1.4-33.1.4-4~deb9u3build0.18.04.13.1.4-4~deb9u5build0.18.04.1 |
3.1.4-4~deb9u5ubuntu0.1~esm2 |
spipUbuntu:Pro:20.04:LTS |
before 3.2.7-1ubuntu0.1+esm2, plus listed versions 3.2.4-13.2.5-13.2.7-13.2.7-1ubuntu0.1 |
3.2.7-1ubuntu0.1+esm2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-28959 is a medium vulnerability (CVSS 6.1) in Spip, published November 25, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.61%, the 75th percentile. Fixed in spip 3.2.8-1.
References
thinkloveshare.com/en/hacking/rce_on_spip_and_root_me
blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-SPIP-3-2-8-et-SPIP-3-1-13.html
root-me.org/fr/Informations/Faiblesses-decouvertes
github.com/spip/SPIP/commit/0394b44774555ae8331b6e65e35065dfa0bb41e4
github.com/spip/SPIP/commit/6c1650713fc948318852ace759aab8f1a84791cf
nvd.nist.gov/vuln/detail/CVE-2022-28959
Show 14 moreShow less
github.com/advisories/GHSA-hq48-7c77-c44g
security-tracker.debian.org/tracker/CVE-2022-28959
ubuntu.com/security/CVE-2022-28959
thinkloveshare.com/hacking/rce_on_spip_and_root_me
cve.org/CVERecord?id=CVE-2022-28959
ubuntu.com/security/notices/USN-7318-1
ubuntu.com/security/notices/USN-8150-1
ubuntu.com/security/CVE-2022-23638
ubuntu.com/security/CVE-2022-28960
ubuntu.com/security/CVE-2022-28961
ubuntu.com/security/CVE-2022-37155
ubuntu.com/security/CVE-2023-24258
ubuntu.com/security/CVE-2023-27372
ubuntu.com/security/CVE-2024-8517