Every CVE Search/ Get API key

CVE-2022-23638

Cross-site Scripting in svg-sanitizer

6.2 MediumFix available

svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the svg-sanitizer library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.68%Down 0.2 points since Feb 15, 2022
90%50%10%1%

What each source reports

CVE List Score used 6.2

Cross-site Scripting in svg-sanitizer

svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the svg-sanitizer library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

Record
CVE-2022-23638
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-0990 6.2

svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the svg-sanitizer library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

Record
EUVD-2022-0990
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-fqx8-v33p-4qcc 6.2

Cross-site Scripting in enshrined/svg-sanitize

Impact

SVG sanitizer library before version 0.15.0 did not remove HTML elements wrapped in a CDATA section. As a result, SVG content embedded in HTML (fetched as text/html) was susceptible to cross-site scripting. Plain SVG files (fetched as image/svg+xml) were not affected.

Patches

This issue is fixed in 0.15.0 and higher.

Workarounds

There is currently no workaround available without upgrading.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-fqx8-v33p-4qcc
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-79
Updated
2026-11-02
NVD 6.2

svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the svg-sanitizer library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

Record
CVE-2022-23638
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.2

Cross-site Scripting in svg-sanitizer

svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the svg-sanitizer library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

Record
CVE-2022-23638
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-fqx8-v33p-4qcc 6.2

Cross-site Scripting in enshrined/svg-sanitize

Impact

SVG sanitizer library before version 0.15.0 did not remove HTML elements wrapped in a CDATA section. As a result, SVG content embedded in HTML (fetched as text/html) was susceptible to cross-site scripting. Plain SVG files (fetched as image/svg+xml) were not affected.

Patches

This issue is fixed in 0.15.0 and higher.

Workarounds

There is currently no workaround available without upgrading.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-fqx8-v33p-4qcc
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2022-23638 6.2

svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the svg-sanitizer library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

Record
UBUNTU-CVE-2022-23638
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUSN-7318-1 No score

spip vulnerabilities

It was discovered that svg-sanitizer, vendored in SPIP, did not properly sanitize SVG/XML content. An attacker could possibly use this issue to perform cross site scripting. This issue only affected Ubuntu 24.10. (CVE-2022-23638)

It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform cross site scripting. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28959)

It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform PHP injection attacks. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28960)

It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28961)

It was discovered that SPIP did not properly sanitize certain inputs. A remote authenticated attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-37155)

It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2023-24258)

It was discovered that SPIP did not properly handle serialization under certain circumstances. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2023-27372)

It was discovered that SPIP did not properly sanitize HTTP requests. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2024-8517)

Record
USN-7318-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
enshrined/svg-sanitize
Packagist
before 0.15.0
0.15.0
enshrined/svg-sanitize
Packagist
before 0.15.0, plus listed versions
0.1.00.1.10.1.20.1.30.1.4
Show 31 moreShow less
0.1.50.1.60.10.00.11.00.12.00.13.00.13.10.13.20.13.30.14.00.14.10.2.00.2.10.3.00.4.00.4.10.5.00.5.10.5.20.5.30.5.3.10.6.00.7.00.7.10.7.20.8.00.8.10.8.20.9.00.9.10.9.2
0.15.0
spip
Ubuntu:22.04:LTS
All versions, plus listed versions
3.2.11-33.2.12-14.0.2-14.0.4-1
None known
spip
Ubuntu:24.04:LTS
All versions, plus listed versions
4.1.11+dfsg-14.1.12+dfsg-14.1.13+dfsg-14.1.15+dfsg-14.2.9+dfsg-2
None known
spip
Ubuntu:25.10
All versions, plus listed versions
4.3.8+dfsg-14.4.3+dfsg-1
None known
spip
Ubuntu:26.10
All versions, plus listed versions
4.4.9+dfsg-14.4.15+dfsg-14.4.16+dfsg-14.4.19+dfsg-14.4.20+dfsg-14.4.21+dfsg-1
None known
spip
Ubuntu:26.04:LTS
All versions, plus listed versions
4.4.3+dfsg-14.4.6+dfsg-14.4.7+dfsg-14.4.8+dfsg-14.4.9+dfsg-1
None known
spip
Ubuntu:Pro:18.04:LTS
before 3.1.4-4~deb9u5ubuntu0.1~esm2, plus listed versions
3.1.4-33.1.4-4~deb9u3build0.18.04.13.1.4-4~deb9u5build0.18.04.1
3.1.4-4~deb9u5ubuntu0.1~esm2
spip
Ubuntu:Pro:20.04:LTS
before 3.2.7-1ubuntu0.1+esm2, plus listed versions
3.2.4-13.2.5-13.2.7-13.2.7-1ubuntu0.1
3.2.7-1ubuntu0.1+esm2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-23638 is a medium vulnerability (CVSS 6.2) in Darylldoyle Svg-sanitizer, published February 14, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in enshrined/svg-sanitize 0.15.0.

References

Show 12 moreShow less
MoveEnter Open