Every CVE Search/ Get API key

CVE-2022-32222

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0...

5.3 MediumFix available

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

2.19%Up 1.3 points since Jul 15, 2022
90%50%10%1%

What each source reports

NVD Score used 5.3

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Record
CVE-2022-32222
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-310, CWE-427
Updated
2026-11-02
CVE List No score

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Record
CVE-2022-32222
Weakness
CWE-310
Updated
2026-11-02
EUVDEUVD-2022-53423 No score

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Record
EUVD-2022-53423
Updated
2026-11-02
GitHub AdvisoriesGHSA-fxfc-w6xq-5pp8 5.3

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0...

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Record
GHSA-fxfc-w6xq-5pp8
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-326, CWE-427
Updated
2026-11-02
OSVALPINE-CVE-2022-32222 5.3

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Record
ALPINE-CVE-2022-32222
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-03
OSVBIT-node-2022-32222 No score

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Record
BIT-node-2022-32222
Updated
2026-11-02
OSVBIT-node-min-2022-32222 No score

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Record
BIT-node-min-2022-32222
Updated
2026-11-02
OSV No score

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Record
CVE-2022-32222
Weakness
CWE-310
Updated
2026-11-02
OSVMGASA-2022-0294 No score

Updated nodejs packages fix security vulnerability

The npm ci command in npm 7.x and 8.x through 8.1.3 proceeds with an installation even if dependency information in package-lock.json differs from package.json. This behavior is inconsistent with the documentation, and makes it easier for attackers to install malware that was supposed to have been blocked by an exact version match requirement in package-lock.json. (CVE-2021-43616)

DNS rebinding in --inspect via invalid IP addresses (CVE-2022-32212)

HTTP Request Smuggling - Flawed Parsing of Transfer-Encoding (CVE-2022-32213)

HTTP Request Smuggling - Improper Delimiting of Header Fields (CVE-2022-32214)

HTTP Request Smuggling - Incorrect Parsing of Multi-line Transfer-Encoding (CVE-2022-32215)

Attempt to read openssl.cnf from /home/iojs/build/ upon startup (CVE-2022-32222)

Record
MGASA-2022-0294
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nodejs-current
Alpine:v3.16
before 18.6.0-r0
18.6.0-r018.9.1-r0
nodejs-current
Alpine:v3.17
before 18.6.0-r0
18.6.0-r018.9.1-r0
nodejs-current
Alpine:v3.18
before 18.6.0-r0
18.6.0-r018.9.1-r0
nodejs-current
Alpine:v3.19
before 18.6.0-r0
18.6.0-r018.9.1-r0
nodejs-current
Alpine:v3.20
before 18.6.0-r0
18.6.0-r018.9.1-r0
nodejs-current
Alpine:v3.21
before 18.6.0-r0
18.6.0-r018.9.1-r0
nodejs-current
Alpine:v3.22
before 18.6.0-r0
18.6.0-r018.9.1-r0
nodejs-current
Alpine:v3.23
before 18.6.0-r0
18.6.0-r018.9.1-r0
nodejs-current
Alpine:v3.24
before 18.6.0-r0
18.6.0-r018.9.1-r0
node
Bitnami
18.0.0 up to 18.5.0
18.5.0
node-min
Bitnami
18.0.0 up to 18.5.0
18.5.0
nodejs
Mageia:8
From an advisory covering 6 CVEs
before 14.20.0-1.1.mga8
14.20.0-1.1.mga8

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-32222 is a medium vulnerability (CVSS 5.3) in Nodejs Node, published July 14, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.19%, the 82nd percentile. Fixed in nodejs-current 18.6.0-r0.

References

Show 9 moreShow less
MoveEnter Open