nodejs-current vulnerabilities (Alpine)
60 vulnerabilities.
-
nodejs-currentAlpine A flaw in Node.js Permission Model filesystem enforcement can grant access to paths that do not... 3.6 Low -
nodejs-currentAlpine A flaw in the Node.js `zlib.ZipFile` API can cause it to return bytes that do not belong to the... 3.7 Low -
nodejs-currentAlpine A flaw in Node.js TLS hostname verification allows a certificate with only a DNS SAN to... 6.7 Medium -
nodejs-currentAlpine A flaw in Node.js `crypto` causes the internal entropy caches used by `crypto.randomUUID()`, ... 4.8 Medium -
nodejs-currentAlpine A flaw in Node.js Permission Model filesystem enforcement leaves `fs.realpathSync()` without the... 3.3 Low -
nodejs-currentAlpine A flaw in Node.js TLS hostname verification can cause a server certificate to be validated... 7.4 High -
nodejs-currentAlpine A flaw in Node.js TLS hostname verification allows a certificate without a matching IP address... 7.4 High -
nodejs-currentAlpine A flaw in Node.js DNS resolution allows hostnames containing a NUL byte to be silently truncated... 7.4 High -
nodejs-currentAlpine A flaw in Node.js HTTP Agent connection reuse can cause a client to accept as valid a response... 6.5 Medium -
nodejs-currentAlpine A flaw in Node.js HTTP/2 handling allows `nghttp2_session_mem_send()` to be called re-entrantly... 7.5 High -
nodejs-currentAlpine A flaw in Node.js allows a spoofed `TypedArray` `byteLength` to trigger a reachable assertion in... 6.2 Medium -
nodejs-currentAlpine A flaw in Node.js HTTP client can cause a request desynchronization for Node.js-based forwarding... 3.7 Low -
nodejs-currentAlpine A flaw in Node.js can cause dns.resolveAny() Aborts the Node.js Process When a DNS Response... 5.9 Medium -
nodejs-currentAlpine A flaw in Node.js node:sqlite allows a stale StatementSyncIterator created through DatabaseSync... 5.3 Medium -
nodejs-currentAlpine A flaw in Node.js Permission Model enforcement allows process.report writes (and overwrites)... 3.3 Low -
nodejs-currentAlpine A flaw in Node.js Permission Model enforcement can over-grant filesystem access across radix-tree... 7.5 High -
nodejs-currentAlpine A flaw in Node.js HTTPS Agent connection reuse can cause PFX object-array key collisions,... 4.1 Medium -
nodejs-currentAlpine A flaw in Node.js Permission Model enforcement allows `trace_events.createTracing().enable()`... 3.3 Low -
nodejs-currentAlpine An incomplete fix has been identified in Node.js: HTTPS Agent TLS session reuse skips hostname... 6.3 Medium -
nodejs-currentAlpine Out-of-Bounds Write in Google Brotli Decoder 9.2 Critical -
nodejs-currentAlpine The team has identified a critical vulnerability in the http server of the most recent version of... 6.5 Medium -
nodejs-currentAlpine An attacker can make the Node.js HTTP/2 server completely unavailable by sending a small amount... 8.2 High -
nodejs-currentAlpine Various `node:fs` functions allow specifying paths as either strings or `Uint8Array` objects. In... 9.8 Critical -
nodejs-currentAlpine A previously disclosed vulnerability (CVE-2023-30584) was patched insufficiently in commit... 7.7 High -
nodejs-currentAlpine Maliciously crafted export names in an imported WebAssembly module can inject JavaScript code.... 5.3 Medium -
nodejs-currentAlpine When the Node.js policy feature checks the integrity of a resource against a trusted manifest,... 7.5 High -
nodejs-currentAlpine A weak randomness in WebCrypto keygen vulnerability exists in Node.js 18 due to a change with... 9.1 Critical -
nodejs-currentAlpine The llhttp parser in the http module in Node v18.7.0 does not correctly handle header fields that... 6.5 Medium -
nodejs-currentAlpine A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0... 5.3 Medium -
nodejs-currentAlpine The llhttp parser in the http module in Node v17.6.0 does not correctly handle multi-line... 6.5 Medium -
nodejs-currentAlpine llhttp allows HTTP Request Smuggling via Improper Delimiting of Header Fields 6.5 Medium -
nodejs-currentAlpine llhttp allows HTTP Request Smuggling via Flawed Parsing of Transfer-Encoding 6.5 Medium -
nodejs-currentAlpine A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due... 8.1 High -
nodejs-currentAlpine Due to the formatting logic of the "console.table()" function it was not safe to allow user... 8.2 High -
nodejs-currentAlpine Moderate: nodejs:14 security update 5.3 Medium -
nodejs-currentAlpine Node.js < 12.22.9, < 14.18.3, < 16.13.2, and < 17.3.1 converts SANs (Subject Alternative Names)... 5.3 Medium -
nodejs-currentAlpine Accepting arbitrary Subject Alternative Name (SAN) types, unless a PKI is specifically defined to... 7.4 High -
nodejs-currentAlpine The parser in accepts requests with a space (SP) right after the header name before the colon.... 6.5 Medium -
nodejs-currentAlpine The parse function in llhttp < 2.1.4 and < 6.0.6. ignores chunk extensions when parsing the body... 6.5 Medium -
nodejs-currentAlpine If the Node.js https API was used incorrectly and "undefined" was in passed for the ... 5.3 Medium -
nodejs-currentAlpine Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS,... 9.8 Critical -
nodejs-currentAlpine A flaw was found in c-ares library, where a missing input validation check of host names returned... 5.6 Medium -
nodejs-currentAlpine Use After Free in node.js 9.8 Critical -
nodejs-currentAlpine Node.js bad 7.5 High -
nodejs-currentAlpine Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack... 7.5 High -
nodejs-currentAlpine Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 allow two copies of a header field in... 6.5 Medium -
nodejs-currentAlpine Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 are vulnerable to a use-after-free bug... 8.1 High -
nodejs-currentAlpine Uncontrolled Resource Consumption in node 7.5 High -
nodejs-currentAlpine Node.js < 12.18.4 and < 14.11 can be exploited to perform HTTP desync attacks and deliver... 7.4 High -
nodejs-currentAlpine Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests... 7.5 High - Show olderLoading…