Every CVE Search/ Get API key

CVE-2020-8251

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests...

7.5 HighFix available

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

8.36%Up 6.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Record
CVE-2020-8251
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-400
Updated
2026-11-02
CVE List No score

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Record
CVE-2020-8251
Weakness
CWE-400
Updated
2026-11-02
EUVDEUVD-2020-29121 No score

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Record
EUVD-2020-29121
Updated
2026-11-02
GitHub AdvisoriesGHSA-9cwr-72m4-73jq 7.5

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests...

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Record
GHSA-9cwr-72m4-73jq
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
OSVALPINE-CVE-2020-8251 7.5

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Record
ALPINE-CVE-2020-8251
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVBELL-CVE-2020-8251 7.5

CVE-2020-8251 does not affect BellSoft software

Record
BELL-CVE-2020-8251
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSV 7.5

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Record
CVE-2020-8251
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVBIT-node-2020-8251 No score

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Record
BIT-node-2020-8251
Updated
2026-11-02
OSVBIT-node-min-2020-8251 No score

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

Record
BIT-node-min-2020-8251
Updated
2026-11-02
OSVopenSUSE-SU-2024:11096-1 No score

nodejs14-14.17.5-1.2 on GA media

These are all security issues fixed in the nodejs14-14.17.5-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11096-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nodejs-current
Alpine:v3.13
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.14
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.15
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.16
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.17
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.18
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.19
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.20
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.21
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.22
before 14.11.0-r0
14.11.0-r0
Show 5 moreShow less
Affected packages
PackageAffectedFixed
nodejs-current
Alpine:v3.23
before 14.11.0-r0
14.11.0-r0
nodejs-current
Alpine:v3.24
before 14.11.0-r0
14.11.0-r0
node
Bitnami
14.0.0 up to 14.11.0
14.11.0
node-min
Bitnami
14.0.0 up to 14.11.0
14.11.0
nodejs14
openSUSE:Tumbleweed
From an advisory covering 19 CVEs
before 14.17.5-1.2
14.17.5-1.2

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-8251 is a high vulnerability (CVSS 7.5) in Nodejs Node, published September 18, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.36%, the 94th percentile. Fixed in nodejs-current 14.11.0-r0.

References

Show 23 moreShow less
MoveEnter Open