Every CVE Search/ Get API key

CVE-2022-45062

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection...

9.8 CriticalFix available

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.77%Up 0.8 points since Nov 9, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.

Record
CVE-2022-45062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-88
Updated
2026-11-02
CVE List 9.8

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.

Record
CVE-2022-45062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-88
Updated
2026-11-02
EUVDEUVD-2022-47984 9.8

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.

Record
EUVD-2022-47984
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-5684-vxhc-x77c 9.8

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection...

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.

Record
GHSA-5684-vxhc-x77c
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-88
Updated
2026-11-02
OSV 9.8

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.

Record
CVE-2022-45062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-45062 9.8

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.

Record
DEBIAN-CVE-2022-45062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
Show 4 moreShow less
OSVOESA-2022-2105 9.8

xfce4-settings security update

This package includes the settings manager applications for the Xfce desktop.

Security Fix(es):

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.(CVE-2022-45062)

Record
OESA-2022-2105
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2022-45062 9.8

In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.

Record
UBUNTU-CVE-2022-45062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2022-0471 No score

Updated xfce4-settings packages fix security vulnerability

argument injection vulnerability in xfce4-mime-helper from the xfce4-settings package.

Record
MGASA-2022-0471
Updated
2026-11-02
OSVUSN-6141-1 No score

xfce4-settings vulnerability

Robin Peraglie and Johannes Moritz discovered that xfce4-settings incorrectly parsed quoted input when processed through xdg-open. A remote attacker could possibly use this issue to inject arbitrary arguments into the default browser or file manager.

Record
USN-6141-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xfce4-settings
Debian:12
before 4.16.4-1
4.16.4-1
xfce4-settings
Debian:13
before 4.16.4-1
4.16.4-1
xfce4-settings
Debian:14
before 4.16.4-1
4.16.4-1
xfce4-settings
Debian:11
before 4.16.0-1+deb11u1, plus listed versions
4.16.0-1
4.16.0-1+deb11u1
xfce4-settings
Mageia:8
before 4.16.0-2.1.mga8
4.16.0-2.1.mga8
xfce4-settings
openEuler:22.03-LTS
before 4.16.0-2.oe2203
4.16.0-2.oe2203
xfce4-settings
Ubuntu:22.04:LTS
before 4.16.2-1ubuntu2.22.04.1, plus listed versions
4.16.2-1ubuntu14.16.2-1ubuntu2
4.16.2-1ubuntu2.22.04.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-45062 is a critical vulnerability (CVSS 9.8) in Xfce Xfce4-settings, published November 9, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.77%, the 78th percentile. Fixed in xfce4-settings 4.16.4-1.

References

Show 13 moreShow less
MoveEnter Open