CVE-2022-45062
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection...
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
- Record
CVE-2022-45062- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-88
- Updated
- 2026-11-02
CVE List
9.8
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
- Record
CVE-2022-45062- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-88
- Updated
- 2026-11-02
EUVDEUVD-2022-47984
9.8
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
- Record
EUVD-2022-47984- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5684-vxhc-x77c
9.8
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection...
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
- Record
GHSA-5684-vxhc-x77c- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-88
- Updated
- 2026-11-02
OSV
9.8
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
- Record
CVE-2022-45062- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-45062
9.8
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
- Record
DEBIAN-CVE-2022-45062- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
Show 4 moreShow less
OSVOESA-2022-2105
9.8
xfce4-settings security update
This package includes the settings manager applications for the Xfce desktop.
Security Fix(es):
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.(CVE-2022-45062)
- Record
OESA-2022-2105- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-45062
9.8
In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
- Record
UBUNTU-CVE-2022-45062- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2022-0471 No score
Updated xfce4-settings packages fix security vulnerability
argument injection vulnerability in xfce4-mime-helper from the xfce4-settings package.
- Record
MGASA-2022-0471- Updated
- 2026-11-02
OSVUSN-6141-1 No score
xfce4-settings vulnerability
Robin Peraglie and Johannes Moritz discovered that xfce4-settings incorrectly parsed quoted input when processed through xdg-open. A remote attacker could possibly use this issue to inject arbitrary arguments into the default browser or file manager.
- Record
USN-6141-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xfce4-settingsDebian:12 |
before 4.16.4-1 | 4.16.4-1 |
xfce4-settingsDebian:13 |
before 4.16.4-1 | 4.16.4-1 |
xfce4-settingsDebian:14 |
before 4.16.4-1 | 4.16.4-1 |
xfce4-settingsDebian:11 |
before 4.16.0-1+deb11u1, plus listed versions 4.16.0-1 |
4.16.0-1+deb11u1 |
xfce4-settingsMageia:8 |
before 4.16.0-2.1.mga8 | 4.16.0-2.1.mga8 |
xfce4-settingsopenEuler:22.03-LTS |
before 4.16.0-2.oe2203 | 4.16.0-2.oe2203 |
xfce4-settingsUbuntu:22.04:LTS |
before 4.16.2-1ubuntu2.22.04.1, plus listed versions 4.16.2-1ubuntu14.16.2-1ubuntu2 |
4.16.2-1ubuntu2.22.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-45062 is a critical vulnerability (CVSS 9.8) in Xfce Xfce4-settings, published November 9, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.77%, the 78th percentile. Fixed in xfce4-settings 4.16.4-1.
References
gitlab.xfce.org/xfce/xfce4-settings/-/issues/390
gitlab.xfce.org/xfce/xfce4-settings/-/commit/55e3c5fb667e96ad1412cf249879262b369d28d7
gitlab.xfce.org/xfce/xfce4-settings/-/commit/f34a92a84f96268ad24a7a13fd5edc9f1d526110
gitlab.xfce.org/xfce/xfce4-settings/-/tags
debian.org/security/2022/dsa-5296
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XGTGTTPFHDUB3EZHVKDK4H32QUUYPPFF
Show 13 moreShow less
security.gentoo.org/glsa/202305-05
nvd.nist.gov/vuln/detail/CVE-2022-45062
lists.fedoraproject.org/archives/list/[email protected]/message/XGTGTTPFHDUB3EZHVKDK4H32QUUYPPFF
github.com/advisories/GHSA-5684-vxhc-x77c
github.com/CVEProject/cvelistV5/tree/main/cves/2022/45xxx/CVE-2022-45062.json
security-tracker.debian.org/tracker/CVE-2022-45062
advisories.mageia.org/MGASA-2022-0471.html
bugs.mageia.org/show_bug.cgi?id=31237
lists.fedoraproject.org/archives/list/[email protected]/thread/H2VXO6JTWDSNXI34DHFAZIN7PGCR4BLI
openeuler.org/en/security/safety-bulletin/detail.html?id=openEuler-SA-2022-2105
ubuntu.com/security/CVE-2022-45062
ubuntu.com/security/notices/USN-6141-1
cve.org/CVERecord?id=CVE-2022-45062