CVE-2023-0299
Improper Input Validation in publify/publify
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.4
Improper Input Validation in publify/publify
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2023-0299- CVSS 3.0
- 8.4 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2023-0526
8.4
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
- Record
EUVD-2023-0526- CVSS 3.0
- 8.4 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-q3rm-f527-ghxj
9.8
Publify Improper Input Validation vulnerability
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
- Record
GHSA-q3rm-f527-ghxj- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
NVD
9.8
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2023-0299- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.4 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
8.4
Improper Input Validation in publify/publify
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2023-0299- CVSS 3.0
- 8.4 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-q3rm-f527-ghxj
9.8
Publify Improper Input Validation vulnerability
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
- Record
GHSA-q3rm-f527-ghxj- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVBIT-publify-2023-0299 No score
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
- Record
BIT-publify-2023-0299- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
before 9.2.10 | 9.2.10 |
publifyBitnami |
before 9.2.10 | 9.2.10 |
publify_coreRubyGems |
before 9.2.10, plus listed versions 9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4 Show 14 moreShow less9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.69.2.79.2.89.2.9 |
9.2.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-0299 is a high vulnerability (CVSS 8.4) in Publify Publify/publify, published January 14, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.94%, the 60th percentile. Fixed in publify_core 9.2.10.
References
huntr.dev/bounties/0049774b-1857-46dc-a834-f1fb15138c53
github.com/publify/publify/commit/ca46da283572b4f8c0b5aa245008756c8a5fd1b1
nvd.nist.gov/vuln/detail/CVE-2023-0299
github.com/publify/publify_core/commit/34f6e9c98e0e3b3f9896f9676b3d6442220e2b4e
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2023-0299.yml
github.com/advisories/GHSA-q3rm-f527-ghxj
github.com/CVEProject/cvelistV5/tree/main/cves/2023/0xxx/CVE-2023-0299.json
github.com/publify/publify