Every CVE Search/ Get API key

CVE-2023-0299

Improper Input Validation in publify/publify

8.4 HighFix available

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.94%Up 0.1 points since Jan 15, 2023
90%50%10%1%

What each source reports

CVE List Score used 8.4

Improper Input Validation in publify/publify

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Record
CVE-2023-0299
CVSS 3.0
8.4 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2023-0526 8.4

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Record
EUVD-2023-0526
CVSS 3.0
8.4 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-q3rm-f527-ghxj 9.8

Publify Improper Input Validation vulnerability

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Record
GHSA-q3rm-f527-ghxj
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
NVD 9.8

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Record
CVE-2023-0299
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
8.4 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 8.4

Improper Input Validation in publify/publify

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Record
CVE-2023-0299
CVSS 3.0
8.4 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-q3rm-f527-ghxj 9.8

Publify Improper Input Validation vulnerability

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Record
GHSA-q3rm-f527-ghxj
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVBIT-publify-2023-0299 No score

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Record
BIT-publify-2023-0299
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
publify_core
RubyGems
before 9.2.10
9.2.10
publify
Bitnami
before 9.2.10
9.2.10
publify_core
RubyGems
before 9.2.10, plus listed versions
9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4
Show 14 moreShow less
9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.69.2.79.2.89.2.9
9.2.10

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-0299 is a high vulnerability (CVSS 8.4) in Publify Publify/publify, published January 14, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.94%, the 60th percentile. Fixed in publify_core 9.2.10.

References

MoveEnter Open