Every CVE Search/ Get API key

CVE-2023-27372

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because...

9.8 CriticalPublic exploitFix available

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

99.7%Up 95.3 points since Mar 1, 2023
90%50%10%1%

What each source reports

NVD Score used 9.8

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Record
CVE-2023-27372
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
CVE List 9.8

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Record
CVE-2023-27372
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
EUVDEUVD-2023-31148 9.8

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Record
EUVD-2023-31148
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-jc3f-vxgp-6jw9 9.8

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because...

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Record
GHSA-jc3f-vxgp-6jw9
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSV 9.8

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Record
CVE-2023-27372
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-27372 9.8

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Record
DEBIAN-CVE-2023-27372
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-27372 9.8

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Record
UBUNTU-CVE-2023-27372
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-7318-1 No score

spip vulnerabilities

It was discovered that svg-sanitizer, vendored in SPIP, did not properly sanitize SVG/XML content. An attacker could possibly use this issue to perform cross site scripting. This issue only affected Ubuntu 24.10. (CVE-2022-23638)

It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform cross site scripting. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28959)

It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform PHP injection attacks. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28960)

It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-28961)

It was discovered that SPIP did not properly sanitize certain inputs. A remote authenticated attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2022-37155)

It was discovered that SPIP did not properly sanitize certain inputs. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2023-24258)

It was discovered that SPIP did not properly handle serialization under certain circumstances. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2023-27372)

It was discovered that SPIP did not properly sanitize HTTP requests. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2024-8517)

Record
USN-7318-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
spip
Debian:13
before 4.1.8+dfsg-1
4.1.8+dfsg-1
spip
Debian:14
before 4.1.8+dfsg-1
4.1.8+dfsg-1
spip
Debian:10
before 3.2.4-1+deb10u10, plus listed versions
3.2.4-13.2.4-1+deb10u13.2.4-1+deb10u23.2.4-1+deb10u33.2.4-1+deb10u4
Show 5 moreShow less
3.2.4-1+deb10u53.2.4-1+deb10u63.2.4-1+deb10u73.2.4-1+deb10u83.2.4-1+deb10u9
3.2.4-1+deb10u10
spip
Debian:11
before 3.2.11-3+deb11u7, plus listed versions
3.2.11-33.2.11-3+deb11u13.2.11-3+deb11u23.2.11-3+deb11u33.2.11-3+deb11u43.2.11-3+deb11u53.2.11-3+deb11u6
3.2.11-3+deb11u7
spip
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.0.20-13.0.21-13.0.21-1ubuntu13.0.21-1ubuntu1+esm1
None known
spip
Ubuntu:Pro:18.04:LTS
before 3.1.4-4~deb9u5ubuntu0.1~esm2, plus listed versions
3.1.4-33.1.4-4~deb9u3build0.18.04.13.1.4-4~deb9u5build0.18.04.1
3.1.4-4~deb9u5ubuntu0.1~esm2
spip
Ubuntu:Pro:20.04:LTS
before 3.2.7-1ubuntu0.1+esm2, plus listed versions
3.2.4-13.2.5-13.2.7-13.2.7-1ubuntu0.1
3.2.7-1ubuntu0.1+esm2
spip
Ubuntu:22.04:LTS
All versions, plus listed versions
3.2.11-33.2.12-14.0.2-14.0.4-1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBSPIP v4.2.0 - Remote Code Execution (Unauthenticated)2023-06-20
MetasploitSPIP form PHP Injection2023-02-27
NucleiSPIP - Remote Command Execution
PoC in GitHub0SPwn/CVE-2023-27372-PoC2023-07-05
PoC in GitHub1Ronkkeli/spip-cve-2023-27372-rce2025-04-28
PoC in GitHub1amthebest1/CVE-2023-273722024-08-15
PoC in GitHubAp0dexMe0/CVE-2023-273722023-07-31
PoC in GitHubChocapikk/CVE-2023-273722023-06-25
PoC in GitHubG01d3nW01f/cve-2023-273722025-07-25
PoC in GitHubKirolosKhairy/CVE-2023-273722025-12-26
Show 6 moreShow less
Public exploits
SourceLinkDate
PoC in GitHubdream434/CVE-2023-273722023-07-01
PoC in GitHubestebanzarate/CVE-2023-27372-SPIP-4.2.1-Unauthenticated-RCE-PoC2026-02-24
PoC in GitHubizzz0/CVE-2023-27372-POC2023-07-11
PoC in GitHubnuts7/CVE-2023-273722023-06-19
PoC in GitHubredboltsec/CVE-2023-27372-PoC2023-09-07
PoC in GitHubscriniariii/CVE-2023-273722026-03-07

History

History
RecordedChangedSources
first indexedCVE List, EUVD, Exploit-DB, GitHub Advisories, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-27372 is a critical vulnerability (CVSS 9.8) in Spip, published February 27, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 99.7%, the 99th percentile. Fixed in spip 4.1.8+dfsg-1.

References

Show 17 moreShow less
MoveEnter Open