CVE-2023-40314
Cross-site scripting in bootstrap.jsp
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer
Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks
Moshe Apelbaum
for reporting this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Adjacent network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.8
Cross-site scripting in bootstrap.jsp
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer
Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks
Moshe Apelbaum
for reporting this issue.
- Record
CVE-2023-40314- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-20, CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2023-2949
5.8
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer
Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks
Moshe Apelbaum
for reporting this issue.
- Record
EUVD-2023-2949- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c6xw-hg9q-3c9f
5.8
OpenNMS Cross-site Scripting vulnerability
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer.
Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
- Record
GHSA-c6xw-hg9q-3c9f- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-20, CWE-79
- Updated
- 2026-11-02
NVD
5.8
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer
Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks
Moshe Apelbaum
for reporting this issue.
- Record
CVE-2023-40314- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-20, CWE-79
- Updated
- 2026-11-02
OSV
5.8
Cross-site scripting in bootstrap.jsp
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer
Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks
Moshe Apelbaum
for reporting this issue.
- Record
CVE-2023-40314- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-20, CWE-79
- Updated
- 2026-11-02
OSVGHSA-c6xw-hg9q-3c9f
5.8
OpenNMS Cross-site Scripting vulnerability
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer.
Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
- Record
GHSA-c6xw-hg9q-3c9f- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-20, CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.opennms:opennms-webappMaven |
before 32.0.5 | 32.0.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-40314 is a medium vulnerability (CVSS 5.8) in Opennms Horizon, published November 16, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.43%, the 38th percentile. Fixed in org.opennms:opennms-webapp 32.0.5.