Every CVE Search/ Get API key

CVE-2023-41752

Apache Traffic Server: s3_auth plugin problem with hash calculation

7.5 HighFix available

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.63%Up 1.6 points since Oct 17, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Record
CVE-2023-41752
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List 7.5

Apache Traffic Server: s3_auth plugin problem with hash calculation

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Record
CVE-2023-41752
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
EUVDEUVD-2023-46244 7.5

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Record
EUVD-2023-46244
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-3vrx-27jg-h7pf 7.5

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server...

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Record
GHSA-3vrx-27jg-h7pf
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVALPINE-CVE-2023-41752 7.5

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Record
ALPINE-CVE-2023-41752
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
OSV 7.5

Apache Traffic Server: s3_auth plugin problem with hash calculation

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Record
CVE-2023-41752
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVDEBIAN-CVE-2023-41752 7.5

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2. Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Record
DEBIAN-CVE-2023-41752
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2023-41752 7.5

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Traffic Server.This issue affects Apache Traffic Server: from 8.0.0 through 8.1.8, from 9.0.0 through 9.2.2. Users are recommended to upgrade to version 8.1.9 or 9.2.3, which fixes the issue.

Record
UBUNTU-CVE-2023-41752
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
trafficserver9
Alpine:v3.21
before 9.2.3-r0
9.2.3-r0
trafficserver9
Alpine:v3.22
before 9.2.3-r0
9.2.3-r0
trafficserver9
Alpine:v3.23
before 9.2.3-r0
9.2.3-r0
trafficserver9
Alpine:v3.24
before 9.2.3-r0
9.2.3-r0
trafficserver
Debian:12
before 9.2.3+ds-1+deb12u1, plus listed versions
9.2.0+ds-29.2.0+ds-2+deb12u19.2.1+ds-19.2.2+ds-19.2.3+ds-1
9.2.3+ds-1+deb12u1
trafficserver
Debian:10
From an advisory covering 2 CVEs
before 8.1.7-0+deb10u3, plus listed versions
8.0.2+ds-18.0.2+ds-1+deb10u18.0.2+ds-1+deb10u28.0.2+ds-1+deb10u38.0.2+ds-1+deb10u4
Show 23 moreShow less
8.0.2+ds-1+deb10u58.0.2+ds-1+deb10u68.0.2+ds-1+deb10u78.0.3+ds-18.0.3+ds-28.0.3+ds-38.0.3+ds-48.0.5+ds-18.0.5+ds-28.0.5+ds-38.0.6+ds-18.0.7+ds-18.0.8+ds-18.0.8+ds-28.1.0+ds-18.1.0+ds-28.1.1+ds-18.1.1+ds-1.18.1.5+ds-1~deb11u18.1.6+ds-1~deb10u18.1.6+ds-1~deb11u18.1.7-0+deb10u18.1.7-0+deb10u2
8.1.7-0+deb10u3
trafficserver
Debian:11
From an advisory covering 4 CVEs
before 8.1.9+ds-1~deb11u1, plus listed versions
8.1.1+ds-1.18.1.1+ds-1.1+deb11u18.1.5+ds-1~deb11u18.1.6+ds-1~deb10u18.1.6+ds-1~deb11u18.1.7+ds-1~deb11u1
8.1.9+ds-1~deb11u1
trafficserver
Debian:12
From an advisory covering 4 CVEs
before 9.2.3+ds-1+deb12u1, plus listed versions
9.2.0+ds-29.2.0+ds-2+deb12u19.2.1+ds-19.2.2+ds-19.2.3+ds-1
9.2.3+ds-1+deb12u1
trafficserver
Ubuntu:16.04:LTS
All versions, plus listed versions
5.3.0-2ubuntu15.3.0-2ubuntu2
None known
trafficserver
Ubuntu:18.04:LTS
All versions, plus listed versions
7.0.0-57.1.2+ds-27.1.2+ds-2build17.1.2+ds-3
None known
trafficserver
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
8.0.5+ds-18.0.5+ds-28.0.5+ds-2build18.0.5+ds-2ubuntu18.0.5+ds-38.0.5+ds-3ubuntu0.1~esm1
None known
trafficserver
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
8.1.1+ds-1.19.1.1+ds-2build19.1.1+ds-2ubuntu0.1~esm19.1.1+ds-2ubuntu0.19.1.1+ds-2ubuntu0.1+esm1
None known

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-41752 is a high vulnerability (CVSS 7.5) in Apache Traffic Server, published October 17, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.63%, the 76th percentile. Fixed in trafficserver9 9.2.3-r0.

References

Show 7 moreShow less
MoveEnter Open