Every CVE Search/ Get API key

CVE-2022-47185

Apache Traffic Server: Invalid Range header causes a crash

7.5 HighFix available

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.00%Up 2.0 points since Aug 9, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.

Record
CVE-2022-47185
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
CVE List 7.5

Apache Traffic Server: Invalid Range header causes a crash

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.

Record
CVE-2022-47185
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2022-49960 7.5

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.

Record
EUVD-2022-49960
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-2fq4-2pvp-hvr5 7.5

Improper input validation vulnerability on the range header in Apache Software Foundation Apache...

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.

Record
GHSA-2fq4-2pvp-hvr5
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 7.5

Apache Traffic Server: Invalid Range header causes a crash

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.

Record
CVE-2022-47185
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVDEBIAN-CVE-2022-47185 7.5

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.

Record
DEBIAN-CVE-2022-47185
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVOESA-2025-2053 7.5

trafficserver security update

Apache Traffic Server is an OpenSource HTTP / HTTPS / HTTP/2 / QUIC reverse, forward and transparent proxy and cache.

Security Fix(es):

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.(CVE-2022-47185)

Record
OESA-2025-2053
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2022-47185 7.5

Improper input validation vulnerability on the range header in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.

Record
UBUNTU-CVE-2022-47185
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
trafficserver
Debian:12
before 9.2.3+ds-1+deb12u1, plus listed versions
9.2.0+ds-29.2.0+ds-2+deb12u19.2.1+ds-19.2.2+ds-19.2.3+ds-1
9.2.3+ds-1+deb12u1
trafficserver
Debian:10
From an advisory covering 2 CVEs
before 8.1.7-0+deb10u2, plus listed versions
8.0.2+ds-18.0.2+ds-1+deb10u18.0.2+ds-1+deb10u28.0.2+ds-1+deb10u38.0.2+ds-1+deb10u4
Show 22 moreShow less
8.0.2+ds-1+deb10u58.0.2+ds-1+deb10u68.0.2+ds-1+deb10u78.0.3+ds-18.0.3+ds-28.0.3+ds-38.0.3+ds-48.0.5+ds-18.0.5+ds-28.0.5+ds-38.0.6+ds-18.0.7+ds-18.0.8+ds-18.0.8+ds-28.1.0+ds-18.1.0+ds-28.1.1+ds-18.1.1+ds-1.18.1.5+ds-1~deb11u18.1.6+ds-1~deb10u18.1.6+ds-1~deb11u18.1.7-0+deb10u1
8.1.7-0+deb10u2
trafficserver
Debian:11
From an advisory covering 4 CVEs
before 8.1.9+ds-1~deb11u1, plus listed versions
8.1.1+ds-1.18.1.1+ds-1.1+deb11u18.1.5+ds-1~deb11u18.1.6+ds-1~deb10u18.1.6+ds-1~deb11u18.1.7+ds-1~deb11u1
8.1.9+ds-1~deb11u1
trafficserver
Debian:12
From an advisory covering 4 CVEs
before 9.2.3+ds-1+deb12u1, plus listed versions
9.2.0+ds-29.2.0+ds-2+deb12u19.2.1+ds-19.2.2+ds-19.2.3+ds-1
9.2.3+ds-1+deb12u1
trafficserver
openEuler:20.03-LTS-SP4
before 9.1.4-4.oe2003sp4
9.1.4-4.oe2003sp4
trafficserver
Ubuntu:16.04:LTS
All versions, plus listed versions
5.3.0-2ubuntu15.3.0-2ubuntu2
None known
trafficserver
Ubuntu:18.04:LTS
All versions, plus listed versions
7.0.0-57.1.2+ds-27.1.2+ds-2build17.1.2+ds-3
None known
trafficserver
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
8.0.5+ds-18.0.5+ds-28.0.5+ds-2build18.0.5+ds-2ubuntu18.0.5+ds-38.0.5+ds-3ubuntu0.1~esm1
None known
trafficserver
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
8.1.1+ds-1.19.1.1+ds-2build19.1.1+ds-2ubuntu0.1~esm19.1.1+ds-2ubuntu0.19.1.1+ds-2ubuntu0.1+esm1
None known

History

History
RecordedChangedSources
affected, factsOSV
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-47185 is a high vulnerability (CVSS 7.5) in Apache Traffic Server, published August 9, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.00%, the 80th percentile. Fixed in trafficserver 9.2.3+ds-1+deb12u1.

References

Show 9 moreShow less
MoveEnter Open