CVE-2023-4197
Dolibarr ERP CRM (<= 18.0.1) Improper Input Sanitization Authenticated RCE
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Dolibarr ERP CRM (<= 18.0.1) Improper Input Sanitization Authenticated RCE
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
- Record
CVE-2023-4197- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2023-3025
7.5
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
- Record
EUVD-2023-3025- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r9cm-pw9j-3fpx
7.5
Dolibarr Improper Input Validation vulnerability
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
- Record
GHSA-r9cm-pw9j-3fpx- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-74
- Updated
- 2026-11-02
NVD
7.5
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
- Record
CVE-2023-4197- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-74
- Updated
- 2026-11-02
OSV
7.5
Dolibarr ERP CRM (<= 18.0.1) Improper Input Sanitization Authenticated RCE
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
- Record
CVE-2023-4197- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-r9cm-pw9j-3fpx
7.5
Dolibarr Improper Input Validation vulnerability
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
- Record
GHSA-r9cm-pw9j-3fpx- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-74
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-4197
7.5
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
- Record
UBUNTU-CVE-2023-4197- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-dolibarr-2023-4197 No score
Dolibarr ERP CRM (<= 18.0.1) Improper Input Sanitization Authenticated RCE
Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.
- Record
BIT-dolibarr-2023-4197- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dolibarr/dolibarrPackagist |
before 18.0.2 | 18.0.2 |
dolibarrBitnami |
through 18.0.1 | None known |
dolibarr/dolibarrPackagist |
before 18.0.2, plus listed versions 10.0.010.0.110.0.210.0.310.0.4 Show 45 moreShow less10.0.510.0.610.0.711.0.011.0.111.0.211.0.311.0.411.0.512.0.012.0.112.0.212.0.312.0.412.0.513.0.013.0.113.0.213.0.313.0.413.0.514.0.014.0.114.0.214.0.314.0.414.0.515.0.015.0.115.0.215.0.33.6.03.6.0-beta3.6.13.6.23.6.33.6.43.6.53.6.63.7.03.7.13.7.23.7.33.7.43.8.0 |
18.0.2 |
dolibarrUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 3.5.5+dfsg1-23.5.7+dfsg1-13.5.8+dfsg1-13.5.8+dfsg1-1ubuntu13.5.8+dfsg1-1ubuntu1+esm1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | alienkeric/CVE-2023-4197 | 2024-05-25 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-4197 is a high vulnerability (CVSS 7.5) in Dolibarr Erp Crm, published November 1, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 36.2%, the 98th percentile. Fixed in dolibarr/dolibarr 18.0.2.
References
starlabs.sg/advisories/23/23-4197
github.com/Dolibarr/dolibarr/commit/0ed6a63fb06be88be5a4f8bcdee83185eee4087e
nvd.nist.gov/vuln/detail/CVE-2023-4197
github.com/advisories/GHSA-r9cm-pw9j-3fpx
github.com/CVEProject/cvelistV5/tree/main/cves/2023/4xxx/CVE-2023-4197.json
github.com/Dolibarr/dolibarr
ubuntu.com/security/CVE-2023-4197
cve.org/CVERecord?id=CVE-2023-4197
Left out here: 62 versions. The JSON record has them.