CVE-2023-42299
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute...
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute arbitrary code and cause a denial of service via the read_subimage_data function.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute arbitrary code and cause a denial of service via the read_subimage_data function.
- Record
CVE-2023-42299- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List No score
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute arbitrary code and cause a denial of service via the read_subimage_data function.
- Record
CVE-2023-42299- Updated
- 2026-11-02
EUVDEUVD-2023-46753 No score
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute arbitrary code and cause a denial of service via the read_subimage_data function.
- Record
EUVD-2023-46753- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-49gh-crhh-42f6
9.8
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute...
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute arbitrary code and cause a denial of service via the read_subimage_data function.
- Record
GHSA-49gh-crhh-42f6- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-42299
9.8
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute arbitrary code and cause a denial of service via the read_subimage_data function.
- Record
DEBIAN-CVE-2023-42299- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-42299
9.8
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute arbitrary code and cause a denial of service via the read_subimage_data function.
- Record
UBUNTU-CVE-2023-42299- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
Buffer Overflow vulnerability in OpenImageIO oiio v.2.4.12.0 allows a remote attacker to execute arbitrary code and cause a denial of service via the read_subimage_data function.
- Record
CVE-2023-42299- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openimageioDebian:12 |
All versions, plus listed versions 2.4.12.0+dfsg-12.4.13.0+dfsg-12.4.14.0+dfsg-12.4.16.0+dfsg-12.4.17.0+dfsg-1 Show 17 moreShow less2.4.17.0+dfsg-1.12.4.7.1+dfsg-22.4.9.0+dfsg-12.5.10.1+dfsg-12.5.12.0+dfsg-12.5.12.0+dfsg-22.5.14.0+dfsg-12.5.15.0+dfsg-12.5.16.0+dfsg-12.5.18.0+dfsg-12.5.19.1+dfsg-12.5.19.1+dfsg-22.5.7.0+dfsg-13.1.18.0+dfsg-13.1.18.0+dfsg-23.1.18.1+dfsg-13.1.18.1+dfsg-2 |
None known |
openimageioDebian:13 |
before 2.4.13.0+dfsg-1 | 2.4.13.0+dfsg-1 |
openimageioDebian:14 |
before 2.4.13.0+dfsg-1 | 2.4.13.0+dfsg-1 |
openimageioUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.5.17~dfsg0-1ubuntu21.5.20~dfsg0-1ubuntu21.5.23~dfsg0-1ubuntu11.6.9~dfsg0-4ubuntu11.6.10~dfsg0-1ubuntu11.6.10~dfsg0-2ubuntu11.6.11~dfsg0-1ubuntu11.6.11~dfsg0-1ubuntu1+esm2 |
None known |
openimageioUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.6.17~dfsg0-1ubuntu51.7.17~dfsg0-1ubuntu21.7.17~dfsg0-1ubuntu2+esm1 |
None known |
openimageioUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 2.0.10~dfsg0-12.0.11~dfsg0-12.0.12~dfsg0-12.0.12~dfsg0-1build12.0.12~dfsg0-1build2 Show 4 moreShow less2.1.10.1~dfsg0-5ubuntu42.1.10.1~dfsg0-5ubuntu52.1.12.0~dfsg0-12.1.12.0~dfsg0-1ubuntu0.1~esm1 |
None known |
openimageioUbuntu:22.04:LTS |
All versions, plus listed versions 2.2.10.1+dfsg-1build12.2.18.0+dfsg-12.2.18.0+dfsg-1build22.2.18.0+dfsg-1ubuntu2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-42299 is a critical vulnerability (CVSS 9.8) in Openimageio, published November 2, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in openimageio 2.4.13.0+dfsg-1.
References
github.com/OpenImageIO/oiio/issues/3840
nvd.nist.gov/vuln/detail/CVE-2023-42299
github.com/advisories/GHSA-49gh-crhh-42f6
github.com/CVEProject/cvelistV5/tree/main/cves/2023/42xxx/CVE-2023-42299.json
security-tracker.debian.org/tracker/CVE-2023-42299
ubuntu.com/security/CVE-2023-42299
github.com/AcademySoftwareFoundation/OpenImageIO/pull/3841
github.com/AcademySoftwareFoundation/OpenImageIO/commit/5ff2c56dd28e96f67ed8f80d8a3d1235e51f9957
cve.org/CVERecord?id=CVE-2023-42299