Every CVE Search/ Get API key

CVE-2023-43887

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and...

8.1 HighFix available

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and num_tile_row parameters in the function pic_parameter_set::dump.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

0.98%Up 0.9 points since Nov 23, 2023
90%50%10%1%

What each source reports

NVD Score used 8.1

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and num_tile_row parameters in the function pic_parameter_set::dump.

Record
CVE-2023-43887
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and num_tile_row parameters in the function pic_parameter_set::dump.

Record
CVE-2023-43887
Updated
2026-11-02
EUVDEUVD-2023-48247 No score

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and num_tile_row parameters in the function pic_parameter_set::dump.

Record
EUVD-2023-48247
Updated
2026-11-03
GitHub AdvisoriesGHSA-6xm3-xq5h-wg4m 8.1

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and...

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and num_tile_row parameters in the function pic_parameter_set::dump.

Record
GHSA-6xm3-xq5h-wg4m
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
OSVDEBIAN-CVE-2023-43887 8.1

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and num_tile_row parameters in the function pic_parameter_set::dump.

Record
DEBIAN-CVE-2023-43887
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-43887 8.1

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and num_tile_row parameters in the function pic_parameter_set::dump.

Record
UBUNTU-CVE-2023-43887
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSV No score

Libde265 v1.0.12 was discovered to contain multiple buffer overflows via the num_tile_columns and num_tile_row parameters in the function pic_parameter_set::dump.

Record
CVE-2023-43887
Updated
2026-11-02
OSVUSN-6677-1 No score

libde265 vulnerabilities

It was discovered that libde265 could be made to dereference invalid memory. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2023-27102)

It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2023-27103)

It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2023-43887, CVE-2023-47471, CVE-2023-49465, CVE-2023-49467, CVE-2023-49468)

Record
USN-6677-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libde265
Debian:12
before 1.0.11-1+deb12u1, plus listed versions
1.0.11-1
1.0.11-1+deb12u1
libde265
Debian:13
before 1.0.13-1
1.0.13-1
libde265
Debian:14
before 1.0.13-1
1.0.13-1
libde265
Debian:10
From an advisory covering 4 CVEs
before 1.0.11-0+deb10u5, plus listed versions
1.0.11-0+deb10u41.0.3-11.0.3-1+deb10u11.0.3-1+deb10u21.0.3-1+deb10u3
Show 6 moreShow less
1.0.4-11.0.7-11.0.8-11.0.8-1.11.0.9-11.0.9-1.1
1.0.11-0+deb10u5
libde265
Ubuntu:Pro:16.04:LTS
before 1.0.2-2ubuntu0.16.04.1~esm4, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm11.0.2-2ubuntu0.16.04.1~esm21.0.2-2ubuntu0.16.04.1~esm3
1.0.2-2ubuntu0.16.04.1~esm4
libde265
Ubuntu:Pro:18.04:LTS
before 1.0.2-2ubuntu0.18.04.1~esm4, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm11.0.2-2ubuntu0.18.04.1~esm21.0.2-2ubuntu0.18.04.1~esm3
1.0.2-2ubuntu0.18.04.1~esm4
libde265
Ubuntu:20.04:LTS
before 1.0.4-1ubuntu0.4, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.11.0.4-1ubuntu0.21.0.4-1ubuntu0.3
1.0.4-1ubuntu0.4
libde265
Ubuntu:22.04:LTS
before 1.0.8-1ubuntu0.3, plus listed versions
1.0.8-11.0.8-1ubuntu0.11.0.8-1ubuntu0.2
1.0.8-1ubuntu0.3
libde265
Ubuntu:Pro:16.04:LTS
From an advisory covering 7 CVEs
before 1.0.2-2ubuntu0.16.04.1~esm4, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm11.0.2-2ubuntu0.16.04.1~esm21.0.2-2ubuntu0.16.04.1~esm3
1.0.2-2ubuntu0.16.04.1~esm4
libde265
Ubuntu:Pro:18.04:LTS
From an advisory covering 7 CVEs
before 1.0.2-2ubuntu0.18.04.1~esm4, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm11.0.2-2ubuntu0.18.04.1~esm21.0.2-2ubuntu0.18.04.1~esm3
1.0.2-2ubuntu0.18.04.1~esm4
libde265
Ubuntu:20.04:LTS
From an advisory covering 7 CVEs
before 1.0.4-1ubuntu0.4, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.11.0.4-1ubuntu0.21.0.4-1ubuntu0.3
1.0.4-1ubuntu0.4
libde265
Ubuntu:22.04:LTS
From an advisory covering 7 CVEs
before 1.0.8-1ubuntu0.3, plus listed versions
1.0.8-11.0.8-1ubuntu0.11.0.8-1ubuntu0.2
1.0.8-1ubuntu0.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-43887 is a high vulnerability (CVSS 8.1) in Struktur Libde265, published November 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in libde265 1.0.11-1+deb12u1.

References

Show 10 moreShow less
MoveEnter Open