Every CVE Search/ Get API key

CVE-2023-46849

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows...

7.5 HighFix available

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.14%Up 1.1 points since Nov 11, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Record
CVE-2023-46849
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-369
Updated
2026-11-02
CVE List 7.5

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Record
CVE-2023-46849
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-369
Updated
2026-11-02
EUVDEUVD-2023-51015 7.5

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Record
EUVD-2023-51015
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-p99v-qjfm-8vvq 7.5

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows...

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Record
GHSA-p99v-qjfm-8vvq
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-369
Updated
2026-11-02
OSVALPINE-CVE-2023-46849 7.5

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Record
ALPINE-CVE-2023-46849
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Record
CVE-2023-46849
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-369
Updated
2026-11-02
OSVDEBIAN-CVE-2023-46849 7.5

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Record
DEBIAN-CVE-2023-46849
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-46849 7.5

Using the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.

Record
UBUNTU-CVE-2023-46849
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:13429-1 No score

openvpn-2.6.7-1.1 on GA media

These are all security issues fixed in the openvpn-2.6.7-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13429-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openvpn
Alpine:v3.18
2.6.0 up to 2.6.7-r0
2.6.7-r0
openvpn
Alpine:v3.19
2.6.0 up to 2.6.7-r0
2.6.7-r0
openvpn
Alpine:v3.20
2.6.0 up to 2.6.7-r0
2.6.7-r0
openvpn
Alpine:v3.21
2.6.0 up to 2.6.7-r0
2.6.7-r0
openvpn
Alpine:v3.22
2.6.0 up to 2.6.7-r0
2.6.7-r0
openvpn
Alpine:v3.23
2.6.0 up to 2.6.7-r0
2.6.7-r0
openvpn
Alpine:v3.24
2.6.0 up to 2.6.7-r0
2.6.7-r0
openvpn
Debian:12
before 2.6.3-1+deb12u2, plus listed versions
2.6.3-12.6.3-1+deb12u12.6.3-1+deb12u1~bpo11+12.6.3-1+deb12u2~bpo11+1
2.6.3-1+deb12u2
openvpn
Debian:13
before 2.6.7-1
2.6.7-1
openvpn
Debian:14
before 2.6.7-1
2.6.7-1
openvpn
Debian:12
From an advisory covering 2 CVEs
before 2.6.3-1+deb12u2, plus listed versions
2.6.3-12.6.3-1+deb12u12.6.3-1+deb12u1~bpo11+12.6.3-1+deb12u2~bpo11+1
2.6.3-1+deb12u2
openvpn
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 2.6.7-1.1
2.6.7-1.1

History

History
RecordedChangedSources
affected, facts
affected
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-46849 is a high vulnerability (CVSS 7.5) in Openvpn, published November 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.14%, the 66th percentile. Fixed in openvpn 2.6.7-r0.

References

Show 9 moreShow less
MoveEnter Open