CVE-2023-46850
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory...
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
- Record
CVE-2023-46850- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
- Record
CVE-2023-46850- Weakness
- CWE-416
- Updated
- 2026-11-02
EUVDEUVD-2023-51016 No score
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
- Record
EUVD-2023-51016- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-jg57-vh55-3g23
9.8
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory...
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
- Record
GHSA-jg57-vh55-3g23- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSVALPINE-CVE-2023-46850
9.8
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
- Record
ALPINE-CVE-2023-46850- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-46850
9.8
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
- Record
DEBIAN-CVE-2023-46850- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-46850
9.8
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
- Record
UBUNTU-CVE-2023-46850- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
- Record
CVE-2023-46850- Weakness
- CWE-416
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13429-1 No score
openvpn-2.6.7-1.1 on GA media
These are all security issues fixed in the openvpn-2.6.7-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13429-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openvpnAlpine:v3.18 |
2.6.0 up to 2.6.7-r0 | 2.6.7-r0 |
openvpnAlpine:v3.19 |
2.6.0 up to 2.6.7-r0 | 2.6.7-r0 |
openvpnAlpine:v3.20 |
2.6.0 up to 2.6.7-r0 | 2.6.7-r0 |
openvpnAlpine:v3.21 |
2.6.0 up to 2.6.7-r0 | 2.6.7-r0 |
openvpnAlpine:v3.22 |
2.6.0 up to 2.6.7-r0 | 2.6.7-r0 |
openvpnAlpine:v3.23 |
2.6.0 up to 2.6.7-r0 | 2.6.7-r0 |
openvpnAlpine:v3.24 |
2.6.0 up to 2.6.7-r0 | 2.6.7-r0 |
openvpnDebian:12 |
before 2.6.3-1+deb12u2, plus listed versions 2.6.3-12.6.3-1+deb12u12.6.3-1+deb12u1~bpo11+12.6.3-1+deb12u2~bpo11+1 |
2.6.3-1+deb12u2 |
openvpnDebian:13 |
before 2.6.7-1 | 2.6.7-1 |
openvpnDebian:14 |
before 2.6.7-1 | 2.6.7-1 |
openvpnDebian:12 From an advisory covering 2 CVEs |
before 2.6.3-1+deb12u2, plus listed versions 2.6.3-12.6.3-1+deb12u12.6.3-1+deb12u1~bpo11+12.6.3-1+deb12u2~bpo11+1 |
2.6.3-1+deb12u2 |
openvpnopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 2.6.7-1.1 | 2.6.7-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-46850 is a critical vulnerability (CVSS 9.8) in Openvpn, published November 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.00%, the 80th percentile. Fixed in openvpn 2.6.7-r0.
References
community.openvpn.net/openvpn/wiki/CVE-2023-46850
openvpn.net/security-advisory/access-server-security-update-cve-2023-46849-cve-2023-46850
debian.org/security/2023/dsa-5555
lists.fedoraproject.org/archives/list/[email protected]/message/L3FS46ANNTAVLIQY56ZKGM5CBTRVBUNE
lists.fedoraproject.org/archives/list/[email protected]/message/O54I7D753V6PU6XBU26FEROD2DSHEJQ4
nvd.nist.gov/vuln/detail/CVE-2023-46850
Show 9 moreShow less
github.com/advisories/GHSA-jg57-vh55-3g23
security.alpinelinux.org/vuln/CVE-2023-46850
github.com/CVEProject/cvelistV5/tree/main/cves/2023/46xxx/CVE-2023-46850.json
security-tracker.debian.org/tracker/CVE-2023-46850
ubuntu.com/security/CVE-2023-46850
ubuntu.com/security/notices/USN-6484-1
cve.org/CVERecord?id=CVE-2023-46850
suse.com/security/cve/CVE-2023-46849
suse.com/security/cve/CVE-2023-46850