Every CVE Search/ Get API key

CVE-2023-47204

transmute-core unsafe YAML deserialization vulnerability

9.8 CriticalFix available

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.95%Up 0.9 points since Nov 2, 2023
90%50%10%1%

What each source reports

NVD Score used 9.8

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Record
CVE-2023-47204
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
CVE List 9.8

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Record
CVE-2023-47204
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
EUVDEUVD-2023-0249 9.8

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Record
EUVD-2023-0249
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-w9cp-3x79-2p8p 9.3

transmute-core unsafe YAML deserialization vulnerability

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Record
GHSA-w9cp-3x79-2p8p
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSV 9.8

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Record
CVE-2023-47204
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-w9cp-3x79-2p8p 9.3

transmute-core unsafe YAML deserialization vulnerability

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Record
GHSA-w9cp-3x79-2p8p
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSVPYSEC-2023-223 No score

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Record
PYSEC-2023-223
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
transmute-core
PyPI
before 1.13.5
1.13.5
transmute-core
PyPI
before 1.13.5, plus listed versions
0.1.00.1.0b00.1.10.1.30.1.4
Show 45 moreShow less
0.1.4b00.1.50.1.60.2.00.2.10.2.100.2.110.2.120.2.20.2.30.2.40.2.50.2.60.2.70.2.80.2.90.3.00.3.10.4.00.4.10.4.100.4.110.4.120.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.6.01.0.01.0.11.1.01.1.11.10.11.11.01.12.01.13.01.13.11.13.21.13.31.13.4
1.13.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-47204 is a critical vulnerability (CVSS 9.8) in Toumorokoshi Transmute-core, published November 2, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.95%, the 61st percentile. Fixed in transmute-core 1.13.5.

References

This page doesn't list everything

Left out here: 23 versions. The JSON record has them.

MoveEnter Open