CVE-2023-47350
Cross Site Request Forgery in SwiftyEdit
Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System prior to v1.2.0, allows remote attackers to escalate privileges via the user password update functionality.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System prior to v1.2.0, allows remote attackers to escalate privileges via the user password update functionality.
- Record
CVE-2023-47350- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System prior to v1.2.0, allows remote attackers to escalate privileges via the user password update functionality.
- Record
CVE-2023-47350- Updated
- 2026-11-02
EUVDEUVD-2023-2841 No score
Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System prior to v1.2.0, allows remote attackers to escalate privileges via the user password update functionality.
- Record
EUVD-2023-2841- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2492-xxqf-6h78
8.8
Cross Site Request Forgery in SwiftyEdit
SwiftyEdit Content Management System prior to v1.2.0 is vulnerable to Cross Site Request Forgery (CSRF).
- Record
GHSA-2492-xxqf-6h78- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVGHSA-2492-xxqf-6h78
8.8
Cross Site Request Forgery in SwiftyEdit
SwiftyEdit Content Management System prior to v1.2.0 is vulnerable to Cross Site Request Forgery (CSRF).
- Record
GHSA-2492-xxqf-6h78- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV No score
Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System prior to v1.2.0, allows remote attackers to escalate privileges via the user password update functionality.
- Record
CVE-2023-47350- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
swiftyedit/swiftyeditPackagist |
before 1.2.0 | 1.2.0 |
swiftyedit/swiftyeditPackagist |
before 1.2.0, plus listed versions v1.0.0v1.1.0v1.1.2 |
1.2.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-47350 is a high vulnerability (CVSS 8.8) in Swiftyedit, published November 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. Fixed in swiftyedit/swiftyedit 1.2.0.
References
github.com/SwiftyEdit/SwiftyEdit/commit/90a6f3df16cd1578b2827d7b2e073451f7ce4e47
mechaneus.github.io/CVE-2023-47350.html
nvd.nist.gov/vuln/detail/CVE-2023-47350
github.com/advisories/GHSA-2492-xxqf-6h78
github.com/CVEProject/cvelistV5/tree/main/cves/2023/47xxx/CVE-2023-47350.json
github.com/SwiftyEdit/SwiftyEdit