Every CVE Search/ Get API key

CVE-2023-47379

Microweber Cross-site Scripting vulnerability

5.4 MediumFix available

Microweber CMS version 2.0.1 is vulnerable to stored Cross Site Scripting (XSS) via the profile picture file upload functionality.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.51%Up 0.5 points since Nov 9, 2023
90%50%10%1%

What each source reports

NVD Score used 5.4

Microweber CMS version 2.0.1 is vulnerable to stored Cross Site Scripting (XSS) via the profile picture file upload functionality.

Record
CVE-2023-47379
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Microweber CMS version 2.0.1 is vulnerable to stored Cross Site Scripting (XSS) via the profile picture file upload functionality.

Record
CVE-2023-47379
Updated
2026-11-02
EUVDEUVD-2023-2992 No score

Microweber CMS version 2.0.1 is vulnerable to stored Cross Site Scripting (XSS) via the profile picture file upload functionality.

Record
EUVD-2023-2992
Updated
2026-11-03
GitHub AdvisoriesGHSA-jmwm-w2rm-prv9 5.4

Microweber Cross-site Scripting vulnerability

Microweber CMS prior to version 2.0.3 is vulnerable to stored Cross Site Scripting (XSS) via the profile picture file upload functionality.

Record
GHSA-jmwm-w2rm-prv9
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-jmwm-w2rm-prv9 5.4

Microweber Cross-site Scripting vulnerability

Microweber CMS prior to version 2.0.3 is vulnerable to stored Cross Site Scripting (XSS) via the profile picture file upload functionality.

Record
GHSA-jmwm-w2rm-prv9
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Microweber CMS version 2.0.1 is vulnerable to stored Cross Site Scripting (XSS) via the profile picture file upload functionality.

Record
CVE-2023-47379
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
microweber/microweber
Packagist
before 2.0.3
2.0.3
microweber/microweber
Packagist
before 2.0.3, plus listed versions
0.9.3460.930.9310.9340.951
Show 32 moreShow less
1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.11v1.2.12v1.2.13v1.2.14v1.2.15v1.2.16v1.2.17v1.2.18v1.2.19v1.2.20v1.2.21v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9v1.3.0v1.3.1v1.3.2v1.3.3v1.3.4v2.0.0v2.0.1
2.0.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-47379 is a medium vulnerability (CVSS 5.4) in Microweber, published November 8, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.51%, the 43rd percentile. Fixed in microweber/microweber 2.0.3.

References

MoveEnter Open