CVE-2023-48699
fastbots Eval Injection vulnerability
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def __locator__(self, locator_name: str) in page.py. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.4
fastbots Eval Injection vulnerability
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def __locator__(self, locator_name: str) in page.py. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.
- Record
CVE-2023-48699- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-95
- Updated
- 2026-11-02
EUVDEUVD-2023-3043
8.4
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def __locator__(self, locator_name: str) in page.py. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.
- Record
EUVD-2023-3043- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vccg-f4gp-45x9
8.4
Eval Injection in fastbots
Impact
An attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def locator(self, locator_name: str) in page.py. The vulnerable code that load and execute directly from the file without validation it's:
return eval(self._bot.locator(self._page_name, locator_name))
Patches
In order to mitigate this issue it's important to upgrade to fastbots version 0.1.5 or above.
References
- Record
GHSA-vccg-f4gp-45x9- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94, CWE-95
- Updated
- 2026-11-02
NVD
8.4
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def __locator__(self, locator_name: str) in page.py. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.
- Record
CVE-2023-48699- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-95, CWE-94
- Updated
- 2026-11-02
OSVGHSA-vccg-f4gp-45x9
8.4
Eval Injection in fastbots
Impact
An attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def locator(self, locator_name: str) in page.py. The vulnerable code that load and execute directly from the file without validation it's:
return eval(self._bot.locator(self._page_name, locator_name))
Patches
In order to mitigate this issue it's important to upgrade to fastbots version 0.1.5 or above.
References
- Record
GHSA-vccg-f4gp-45x9- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94, CWE-95
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fastbotsPyPI |
before 0.1.5 | 0.1.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-48699 is a high vulnerability (CVSS 8.4) in Fastbots, published November 21, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in fastbots 0.1.5.
References
github.com/ubertidavide/fastbots/security/advisories/GHSA-vccg-f4gp-45x9
github.com/ubertidavide/fastbots/pull/3
github.com/ubertidavide/fastbots/commit/73eb03bd75365e112b39877e26ef52853f5e9f57
nvd.nist.gov/vuln/detail/CVE-2023-48699
github.com/advisories/GHSA-vccg-f4gp-45x9
github.com/ubertidavide/fastbots