CVE-2023-49208
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2...
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2 credentials validation in webauthn registration.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2 credentials validation in webauthn registration.
- Record
CVE-2023-49208- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List
9.8
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2 credentials validation in webauthn registration.
- Record
CVE-2023-49208- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2023-53212
9.8
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2 credentials validation in webauthn registration.
- Record
EUVD-2023-53212- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x7rh-wvh4-cx6x
9.8
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2...
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2 credentials validation in webauthn registration.
- Record
GHSA-x7rh-wvh4-cx6x- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
9.8
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2 credentials validation in webauthn registration.
- Record
CVE-2023-49208- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-49208
9.8
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2 credentials validation in webauthn registration.
- Record
DEBIAN-CVE-2023-49208- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-49208
9.8
scheme/webauthn.c in Glewlwyd SSO server before 2.7.6 has a possible buffer overflow during FIDO2 credentials validation in webauthn registration.
- Record
UBUNTU-CVE-2023-49208- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
glewlwydDebian:12 |
before 2.7.5-3+deb12u1, plus listed versions 2.7.5-3 |
2.7.5-3+deb12u1 |
glewlwydDebian:13 |
before 2.7.6+ds-1 | 2.7.6+ds-1 |
glewlwydUbuntu:18.04:LTS |
All versions, plus listed versions 1.1-2ubuntu11.2.2-11.3.1-1 |
None known |
glewlwydUbuntu:20.04:LTS |
All versions, plus listed versions 1.4.9-21.4.9-3 |
None known |
glewlwydUbuntu:22.04:LTS |
All versions, plus listed versions 2.5.2-32.6.1-12.6.1-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-49208 is a critical vulnerability (CVSS 9.8) in Glewlwyd Sso Server Project Sso Server, published November 23, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.88%, the 59th percentile. Fixed in glewlwyd 2.7.5-3+deb12u1.
References
github.com/babelouest/glewlwyd/commit/f9d8c06aae8dfe17e761b18b577ff169e059e812
github.com/babelouest/glewlwyd/releases/tag/v2.7.6
nvd.nist.gov/vuln/detail/CVE-2023-49208
github.com/advisories/GHSA-x7rh-wvh4-cx6x
github.com/CVEProject/cvelistV5/tree/main/cves/2023/49xxx/CVE-2023-49208.json
security-tracker.debian.org/tracker/CVE-2023-49208
ubuntu.com/security/CVE-2023-49208
cve.org/CVERecord?id=CVE-2023-49208